Notifications
Clear all

wpForo 1.x.x [Closed] Pagination lost ...

4 Posts
2 Users
0 Likes
1,437 Views
Posts: 4
Topic starter
(@heiyoo)
Active Member
Joined: 5 years ago

Hi,

I can't find any pagination in my forum. The topics page has no pagination, for example: https://www.hipole.com/bbs/sues/. The posts page has no pagination, for example: https://www.hipole.com/bbs/sues/hec-2019%E5%9B%BE%E9%A9%AC%E6%80%9D%E7%89%B9%E6%9D%AF%E8%B5%9B%E5%AD%A3%E6%8A%95%E8%AF%89%E8%B4%B4/ .

My environment details listed as below:

1. In Topic & Post Settings, number of topics per page in Topic List and number of posts per page on Post List page are both set to 15.

2. Wordpress version 5.1.1, wpForo 1.6.1.

3. wpForo Advanced Attachments is installed.

4. Cached were cleaned up.

Please let me know if you need more info.

Looking forward to solution, thanks in advance.

 

Regards,

Yao

 

Topic Tags
3 Replies
Posts: 4
Topic starter
(@heiyoo)
Active Member
Joined: 5 years ago

Adding some new research results ..

1. After adding "/paged/2/" after the url then I can see the next pages of topics/posts..

2. Checked with release note, my previous version is 1.5.x, so I guess it may be caused by wpforo upgrading...  wpForo Advanced Attachments is latest version now as well.

3. I tried to change the number of topics per page in Topic List and number of posts per page on Post List page in Topic & Post Settings, for example, to change them from 15 to 10. But after saving the settings and a page auto-reload, the numbers are still 15, nothing changed during saving settings. I tried to change some other settings in Topic & Post Settings, all failed. The other tabs works well.

Posts: 4
Topic starter
(@heiyoo)
Active Member
Joined: 5 years ago

I rollback the source files to v1.5.5, the pagination works well. Then I re-upgrade it to v1.6.1 in plugins page, after a successful upgrading, the pagination disappeared.

Now I rollback to v1.5.5 temporarily now.

Robert
Posts: 10478
Admin
(@robert)
Support Team
Joined: 8 years ago

Please update to latest version, then follow to this support topic. First, please ask your hosting support to update MySQL to 5.7 version: https://wpforo.com/community/how-to-and-troubleshooting-2/topic-pages-disappeared/#post-26309

Or add new indexes/keys in wp_wpforo_table described here: https://wpforo.com/community/how-to-and-troubleshooting-2/topic-pages-disappeared/#post-25531

After these changes, don't forget delete all caches, then navigate to Dashboard > Forums > Dashboard admin page and delete forum cache using [Delete all cache] button