Notifications
Clear all

[Closed] Point System (Part 2)

5 Posts
2 Users
2 Likes
367 Views
Posts: 126
Topic starter
(@cotner)
Estimable Member
Joined: 2 years ago

@tutrix In this now closed thread you explained how to add point to profiles and what not.

https://wpforo.com/community/postid/73422/

The specific part up adding it to the profile part is no longer working as is should. Do you have any thoughts on how to fix this?

Here is the original code added to profile-home.php

                <div class="wpf-statbox">
                   <div class="wpf-statbox-icon points" style="background: #fffad5; fill:  #cd9000;">
                        <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" id="Layer_1" x="0px" y="0px" viewBox="0 0 92.31 122.88" style="enable-background:new 0 0 92.31 122.88" xml:space="preserve"><style type="text/css">.st0{fill-rule:evenodd;clip-rule:evenodd;}</style><g><path class="st0" d="M46.16,69.11l3.6,8.8l9.48,0.7l-7.26,6.15L54.24,94l-8.09-5l-8.09,5l2.26-9.24l-7.26-6.15l9.48-0.7 L46.16,69.11L46.16,69.11z M46.84,3.6c0.32-1.64,1.17-2.69,2.33-3.23c0.94-0.43,2.03-0.48,3.17-0.18c0.99,0.26,2.03,0.79,3.03,1.55 c2.7,2.05,5.23,5.93,5.55,10.77c0.1,1.49,0.07,3.08-0.07,4.77c-0.09,1.12-0.24,2.29-0.43,3.51H71.9l0.05,0.01 c1.87,0.07,3.67,0.53,5.2,1.33c1.32,0.69,2.43,1.63,3.2,2.81c0.79,1.21,1.23,2.65,1.16,4.29c-0.05,1.22-0.37,2.54-1.04,3.96 c0.38,1.59,0.56,3.29,0.31,4.79c-0.21,1.27-0.7,2.4-1.59,3.24c0.05,2.1-0.23,3.86-0.8,5.39c-0.58,1.57-1.45,2.87-2.57,4.02 c-0.1,1.01-0.26,1.97-0.51,2.87c-0.32,1.13-0.78,2.17-1.43,3.08l0,0c-1.96,2.76-3.52,2.7-6,2.6c-0.34-0.01-0.72-0.03-1.29-0.03 l-22.47,0c-2.02,0-3.61-0.29-5.06-1.02c-1.44-0.72-2.66-1.82-3.97-3.46l-0.34-0.95V27.5l1.14-0.31c2.9-0.78,5.18-3.26,6.95-6.22 c1.82-3.05,3.1-6.62,3.97-9.5V3.89L46.84,3.6L46.84,3.6L46.84,3.6z M13.09,24.77h16.74c1.27,0,2.3,1.04,2.3,2.3v30.61 c0,1.27-1.04,2.3-2.3,2.3l-16.74,0c-1.27,0-2.3-1.04-2.3-2.3V27.07C10.79,25.8,11.82,24.77,13.09,24.77L13.09,24.77L13.09,24.77z M50.45,3.15c-0.25,0.11-0.45,0.4-0.57,0.9v7.64l-0.07,0.44c-0.93,3.09-2.31,7.01-4.35,10.42c-1.92,3.21-4.41,5.96-7.64,7.24v23.38 c0.89,1.05,1.71,1.77,2.6,2.21c0.99,0.49,2.15,0.69,3.69,0.69l22.47,0c0.4,0,0.92,0.02,1.41,0.04c1.47,0.06,2.4,0.1,3.39-1.31V54.8 c0.43-0.61,0.75-1.33,0.98-2.14c0.24-0.86,0.38-1.81,0.45-2.83l0.47-1.01c0.99-0.94,1.75-1.99,2.23-3.29 c0.49-1.33,0.71-2.94,0.59-4.95l-0.05-0.91l0.77-0.48c0.53-0.33,0.82-0.95,0.94-1.71c0.2-1.21-0.01-2.69-0.39-4.07l0.12-1.11 c0.62-1.19,0.92-2.26,0.96-3.19c0.04-0.97-0.21-1.81-0.67-2.51c-0.48-0.73-1.19-1.33-2.05-1.78c-1.11-0.58-2.44-0.91-3.84-0.97v0 l-15.15,0l0.34-1.82c0.33-1.76,0.57-3.43,0.7-5.02c0.13-1.56,0.16-3,0.07-4.31c-0.26-3.87-2.24-6.93-4.35-8.54 c-0.67-0.51-1.34-0.86-1.95-1.02C51.11,3.03,50.72,3.03,50.45,3.15L50.45,3.15L50.45,3.15z M29.62,97.99l3.6,8.8l9.48,0.7 l-7.26,6.15l2.26,9.24l-8.09-5l-8.09,5l2.26-9.24l-7.26-6.15l9.48-0.7L29.62,97.99L29.62,97.99z M62.69,97.99l3.6,8.8l9.48,0.7 l-7.26,6.15l2.26,9.24l-8.09-5l-8.09,5l2.26-9.24l-7.26-6.15l9.48-0.7L62.69,97.99L62.69,97.99z M79.22,69.11l3.6,8.8l9.48,0.7 l-7.26,6.15L87.31,94l-8.09-5l-8.09,5l2.26-9.24l-7.26-6.15l9.48-0.7L79.22,69.11L79.22,69.11z M13.09,69.11l3.6,8.8l9.48,0.7 l-7.26,6.15L21.17,94l-8.09-5L5,94l2.26-9.24L0,78.61l9.48-0.7L13.09,69.11L13.09,69.11z"></path></g></svg>
                        </div>
                    <div class="wpf-statbox-data">
                        <div class="wpf-statbox-value"><?php wpforo_print_number( wpfval( WPF()->current_object['user'], 'points' ), true ) ?></div>
                        <div class="wpf-statbox-title">Reputations Points</div>
                    </div>
                </div>       

Attached is an image of what it looks like after the 2.1 update...

 

4 Replies
Tutrix
Posts: 1186
(@tutrix)
Noble Member
Joined: 4 years ago

@cotner

i don't use 2.1 yet, but nothing has changed in profile-home.php
maybe you made a mistake while inserting the code

the svg graphic is not shown, so the rest of the code is shifted

Check the code if all characters are correct

Posts: 126
Topic starter
(@cotner)
Estimable Member
Joined: 2 years ago

@tutrix

It is strange, I am cutting an pasting the code just like I always have for each update that has come along. It was only with 2.1 where it broke things. (I guess 2.1.1 as well)

Posts: 126
Topic starter
(@cotner)
Estimable Member
Joined: 2 years ago

@tutrix

I finally figured this out... It turns out the the CSS portion of this stopped working in the custom WPForo CSS area of my site. When I moved it to the WP theme custom CSS, it started working just fine again. Not sure why it stopped working in the WPForo custom css area.

 

#wpforo #wpforo-wrap .wpf-profile-section .wpf-statbox .wpf-statbox-icon.points svg {width: 30px; height: 30px;}
Tutrix
Posts: 1186
(@tutrix)
Noble Member
Joined: 4 years ago

@cotner

I have created my own wpForo theme and add all my CSS changes directly into the style.css of my theme. 😉