Notifications
Clear all

wpForo 1.x.x [Closed] Problem with the forum slug and WPML

8 Posts
2 Users
0 Reactions
1,255 Views
Posts: 18
Topic starter
(@mi-ning)
Eminent Member
Joined: 3 years ago

I had to change the forum slug to communityforum  because if I name it the same as the page, WMPL will not translate (click the spanish version)  

this works when they go to the page but when they go to a forum topic, the url changes and translation at the top is lost.  

please help thanks

7 Replies
Posts: 18
Topic starter
(@mi-ning)
Eminent Member
Joined: 3 years ago

ok now it is really bad,  if I set the forum name to the page, now the forum page redirects 404 because i dont know what to do

Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @mi-ning,

wpForo is not fully compatible with Multi-Lang now. The Dev team is working on wpForo major update(2.0.0), which will be fully compatible with Multi-Lang. So I recommend you to use English for Both Languages Before the 2.0.0 Update Release.

Posts: 18
Topic starter
(@mi-ning)
Eminent Member
Joined: 3 years ago

yes I only made an english page for the moment, it has english and spanish translation on it.  which will work  i think.  except I don't think they will be able to use the forum much, but maybe I can change the translation file

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@mi-ning,

You can Translate English to another Language, But for now you should use only one language for your website, If you want to translate English to another language you can use Loco Translate Plugin which is compatible with wpForo.

Posts: 18
Topic starter
(@mi-ning)
Eminent Member
Joined: 3 years ago

No i wait we paid for wpml maybe we can beta test . For now i made a forum for one language and another for English

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@mi-ning,

wpForo is not compatible with Multi Lang for now, what kind of beta Test are you talking about? 

Page 1 / 2