Notifications
Clear all

[Closed] read-only does not work

3 Posts
2 Users
0 Reactions
387 Views
Posts: 1
Topic starter
(@mmartinezjorge)
New Member
Joined: 1 year ago

Hi, we use role based permissions on our website. We set the following roles and usergroups:

1. Guest- read only must login

2. Member-standard access

3. Restricted- read only

4. Admin- full access

 

For guests it requires login upon testing. However, Restricted usergroup is not working at all. Any member with that usergroup has full access and can post, reply, etc. What am I doing wrong? Any help? 

Also, For guests, I would like it to redirect to the websites log in page, not wpforo login. I tried setting it by the link but it still redirects to wpforo. 

Thank you for any help you can provide!

2 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @mmartinezjorge,

About the Read-Only Access, please open it and check the CAN's/options.

Then navigate to Dashboard > wpForo > Forums, Edit the Categories and Forum one by one and check Forum Permissions field. You need to set Read-Only Access for the Restricted Usergroups in that field.

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@mmartinezjorge,

About registration and login.

Navigate to Dashboard > wpForo > Settings > Login & Registration.

See: Enable User Registration option, if you disable this option User won't be able to reg through wpForo only from WordPress Or your custom Login/Reg forms.

 

See: the below Options

  • Replace Registration Page URL to Forum Registration Page URL
  • Replace Login Page URL to Forum Login Page URL
  • Replace Reset Password Page URL to Forum Reset Password Page URL

See: the below options and read their description:

Custom Redirection URLs after following actions:

Note please: That redirect after Registration is only if Enable User Registration email confirmation option is disabled.