Notifications
Clear all

Recapcha not working

16 Posts
3 Users
4 Reactions
370 Views
VereK
Posts: 522
(@verek)
Honorable Member
Joined: 6 years ago

And you have checked the settings in the Dashboard and also the Google reCAPTCHA console?

Reply
1 Reply
(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1157

@verek Yes mate, it seems cache related. I use LightSpeed cache. When i deactivate it, the captcha loads fine.....

I have tried excluding that url from the optimisation, but it is still causing problems. I am not sure what i need ot do to stop this from happening. Frustrating! 

Reply
VereK
Posts: 522
(@verek)
Honorable Member
Joined: 6 years ago

Yeah, not a fan of Litespeed.

Rather than lose new signups I would turn reCAPTCHA off for wpForo. The security reCAPTCHA supposedly adds is negligible anyway. 

Reply
1 Reply
(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1157

@verek I did this but got a warning about the forum not being protected from spam so put it back on again.....

Reply
VereK
Posts: 522
(@verek)
Honorable Member
Joined: 6 years ago

@percysgrowroom 

Have you got any JS and CSS combining going on in Litespeed Cache?

Reply
1 Reply
(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1157

@verek yes mate.... i should go thorugh them and check ay.

Reply
VereK
Posts: 522
(@verek)
Honorable Member
Joined: 6 years ago

Also, instead of an URL exclude try a keyword like wpforo or sign-up or wpforo-register in JS exclude &  defer JS exclude in Litespeed

Reply
3 Replies
(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1157

@verek That hasnt worked either lol 

I was thinking, could I use V3 captcha instead of 2 so there isnt a box to click? 

Reply
VereK
(@verek)
Joined: 6 years ago

Honorable Member
Posts: 522

@percysgrowroom 

wpForo does not work with V3 as far as I know. You could disable JS minify completely in Litespeed or start a support topic at the Litespeed plugin support page? ( https://wordpress.org/support/plugin/litespeed-cache/ )

 

Reply
(@percysgrowroom)
Joined: 5 years ago

Noble Member
Posts: 1157

@verek Thanks mate, ill give that a shot

Reply
Page 2 / 2