Notifications
Clear all

wpForo 1.x.x [Solved] Remove sticky topics from Extended forum Recent topics section

7 Posts
2 Users
5 Likes
1,938 Views
Posts: 21
Topic starter
(@power505)
Eminent Member
Joined: 5 years ago

Right now, if I choose to display recent topics on Extended forums, it will display sticky threads on top.

Let's say I have three sticky threads in the subforum, it will display all of them in the recent section on top of others, no matter how far ago was the last post in them.

Is there a way to display a REAL list of recent topics in recent section?

6 Replies
Sofy
Posts: 4322
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @power505,

If you're using the wpForo 1.6.2 version, please follow the steps below:

1. Copy wp-content/plugins/wpforo/wpf-themes/classic/layouts/1/forum.php file 

2. Paste it in your active theme's wpforo folder, as explained in this doc: https://wpforo.com/docs/root/forum-themes/theme-customization/

3. In copied file go to line 30

4. Remove just the type, part of the code from that line.

5. Finally, it should look as shown in the screenshot below. 

I may suggest another solution you can use. Just change the value for the "Extended Layout - Number of Recent topics" option and set it e.g. 7. 

More info in this doc: https://wpforo.com/docs/root/categories-and-forums/forum-layouts/extended-layout/

 

4 Replies
(@power505)
Joined: 5 years ago

Eminent Member
Posts: 21

@sofy

Sorry for the late reply. Unfortunately, it's the same for me, even after applying yor fix.

I even tried to edit the original file, just to test it, but it's the same even then.

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4322

@power505

Could you please leave a screenshot that shows the final look of the code in your case? 

(@power505)
Joined: 5 years ago

Eminent Member
Posts: 21
Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4322

@power505,

Please navigate to Dashboard > Forums > Dashboard admin page, click on "Delete all caches" button. If you've installed some cache plugins please delete those plugins caches as well. Then press CTRL+F5 (twice) on the frontend. 

 

Posts: 21
Topic starter
(@power505)
Eminent Member
Joined: 5 years ago

As always, I have forgotten this step 🙂

Thank you once again @sofy