Notifications
Clear all

[Solved] Reply button/section not working when Post Id Is In The URL

5 Posts
2 Users
2 Reactions
191 Views
Posts: 4
Topic starter
(@southtech-creations)
Active Member
Joined: 3 months ago

Howdy,

I noticed a recent issue with my forum where if I or others go to a topic with the post ID attached to the end of the URL string (like #161), then (usually) the second-to-last post isn't able to be replied to, liked, etc. It's only if you remove the #NUM that you'll be able to reply/like/etc to the post (UPDATE: I actually just realized that it's the post right above whatever post you're looking at/being sent to based off of the POST ID/#NUM). So for example, if you were to go here: https://digitalmatrixcafe.com/community/feedback-and-support/i-want-to-switch-hosting-but-wpx-asks-for-the-whole-database-and-files/#post-161 , the post above mine you can't like,reply, etc.

I enabled debug mode in case that would be helpful for you guys to check to see what the issue is. I haven't disabled all the plugins and tried turning each one one and seeing if it did anything, which I'll do shortly after this on a staging site. I am using this forum in connected with the BuddyBoss platform/theme.

4 Replies
Sofy
Posts: 4581
 Sofy
Admin
(@sofy)
Support Team
Joined: 7 years ago

Hi,

We were able to like the post and post a reply as well. For further clarification, please refer to the attached video below.

3 Replies
(@southtech-creations)
Joined: 3 months ago

Active Member
Posts: 4

@sofy I must have mispoke - if you click on the link I posted above, it's the post above that one that you just tried, that you can't like/reply on (screenshot to show which one).

Sofy
 Sofy
Admin
(@sofy)
Joined: 7 years ago

Support Team
Posts: 4581

@southtech-creations,

The issue comes from the CSS code shown in the video attached below.

Use the CSS code below to solve the issue:Β 

#wpforo #wpforo-wrap .post-wrap, #wpforo #wpforo-wrap [id^=post-][data-postid] {
    position: static;
}

Insert the code in the Dashboard > wpForo > Settings > Colors & Styles > Custom CSS code textarea.Β 

(@southtech-creations)
Joined: 3 months ago

Active Member
Posts: 4

@sofy That fixed the issue. Thanks!