Notifications
Clear all

wpForo 1.x.x [Solved] Warnings pop up when Role-Usergroup Synchronization turned off

5 Posts
2 Users
1 Likes
1,724 Views
sworden
Posts: 13
Topic starter
(@sworden)
Active Member
Joined: 6 years ago

After the recent update, Role-Usergroup Synchronization is automatically turned on.  I turned it off because while we use the WordPress Subscriber role for most of our users, the users will fall into one of two wpForo usergroups based on whether they are the parent (Customer usergroup) or a student (Registered usergroup).  After I have turned off the synchronization and create a new user, I get several warning popping up on my screen.  (I have attached a file showing the warnings I am getting.)  If I turn the synchronization back off and create a new user, no warnings.  But, I absolutely have to keep synchronization turned off because I need to be able to assign wpForo usergroups manually.  Prior to the recent update, this problem did not occur.  Is there a fix to this problem?

4 Replies
Robert
Posts: 9739
Admin
(@robert)
Support Team
Joined: 7 years ago

It seems the Secondary Usergroups are not installed during the update process. Please enable at least one Usergroup for Secondary usage. Navigate to Dashboard > Forums > Usergroups admin page, edit the Customer or Registered Usergroup and enable the "Can be also used as Secondary Usergroup" option. Then save it.

Reply
sworden
Posts: 13
Topic starter
(@sworden)
Active Member
Joined: 6 years ago

They both already have "Can also be used as a Secondary Usergroup" checked.  When I tried to save them again just to make sure the change was applied, I got the following (attached file) fatal error message.  I noticed that whenever I try to save a usergroup, whether after checking that box or unchecking it or even clicking save when I haven't made any changes at all results in the attached error message.

Reply
Robert
Posts: 9739
Admin
(@robert)
Support Team
Joined: 7 years ago

All problems come from New User Approve plugin. This error also come from that plugin file. So this plugin is not compatible with wpForo.

Reply
sworden
Posts: 13
Topic starter
(@sworden)
Active Member
Joined: 6 years ago

Thank you.  I deactivated the New User Approve plugin and everything is working just fine.  We will find a different plugin.

Reply
Share: