Notifications
Clear all

wpForo 1.x.x [Closed] Theme Layout don't take effect (SSL Issue?)

4 Posts
2 Users
0 Reactions
1,046 Views
Posts: 5
Topic starter
(@denzy)
Active Member
Joined: 5 years ago

I have multiple questions, but i check let you know the main one first.

1. Ok so if edit Forums > Settings > features the changes take effect fine, however if i edit Forums > Settings > Styles ....well the changes don't seem take effect in (https:// mywebsite) but changes take effect if i take SSL out (http:// mywebsite)

2. Also is there a buddypress/wordpress > Avatar....my site the user can set their own avatar on there main profile but on the forums they would have to upload another avatar if they want one it shows the default gravatar on forums

3. Also how can i show the ( Latest Post: // Our newest member: // Recent Posts: // Tags) on the forums statistics?

Would appreciate any help thank you

3 Replies
Robert
Posts: 10523
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @denzy,

For the first question, please navigate to Dashboard > Settings > General admin page and check your WordPress installation URLs. Make sure they with https protocol. Then navigate to Dashboard > Forums > Settings > General Tab, make sure the Forum Base URL is also starts with https protocol and click on [Update Options] button. Then navigate to Dashboard > Forums > Dashboard admin page and click on [Delete All Caches] button, then delete your website cache if you have different cache plugin.

For the second question: wpForo allows users to upload avatars in My Profile > Account page. Also wpForo displays BuddyPress  avatars if the user avatar is set WordPress in the same My Profile > Account page. Just make sure you use the WordPress avatar type and forum avatars will be loaded from BuddyPress profile:

For the third question I can say they are already on forum statistic, they are already in footer statistic bar. What other statistic you mean? In any case I can say there is no way display these data in other places, there is no any shortcode for that.

1 Reply
(@denzy)
Joined: 5 years ago

Active Member
Posts: 5

Hey @robert thanks for the reply but;

I already tried that before everything is set to https:// but still doesn't work 🙄 .....only changes work when i custom change site to http...its strange why it don't take effect on https

Second question i have it set to Forums > Settings > Features > Replace Forum Profile with BuddyPress Profile 'YES'.....even when i put wordpress avatar system i doesn't show the users avatar it only shows a default gravatar  😫 

3rd question, is fine i got it to work...it appeared/updated when i made a post 👍 

Robert
Posts: 10523
Admin
(@robert)
Support Team
Joined: 8 years ago

I already tried that before everything is set to https:// but still doesn't work 🙄 .....only changes work when i custom change site to http...its strange why it don't take effect on https.

I'm sorry but I have no other idea, it works fine on all our test websites. The only thing I suspect is you've not clicked on [Delete all caches] button in Dashboard > Forums > Dashboard admin page after each change. This button also delete users cache and loads new user avatars.

Second question i have it set to Forums > Settings > Features > Replace Forum Profile with BuddyPress Profile 'YES'.....even when i put wordpress avatar system i doesn't show the users avatar it only shows a default gravatar  😫

This option doesn't have any relation to avatars, this only replaces Users Profile URL to BuddyPress Profile URL.