Notifications
Clear all

wpForo 1.x.x [Solved] User registration not working - Wordfence & WpForo

6 Posts
4 Users
2 Reactions
648 Views
Posts: 21
Topic starter
(@cindy_)
Eminent Member
Joined: 1 year ago

Hello,

I just instal WpForo to test it on my website, and try to test new registration on the forum.

After putting my user name and email adresse, there is a red bubble popin on the left corner of the page, saying:

REGISTRATION ATTEMPT BLOCKED: This site requires a security token created when the page loads for all registration attempts. Please ensure JavaScript is enabled and try again.

I think I read all subjects opened here on this forum about this error 😅

So I found a solution, which is to disable the extension Wordfence. But I try to modify the settings of Wordfence, to keep it, but didn't find any option valid...

Does someone have Wordfence AND WpForo working together on their site? 

Thanks a lot,

Best regards.

5 Replies
dimalifragis
Posts: 2614
(@dimalifragis)
Famed Member
Joined: 4 years ago

You have two forums plugins, nice !

This issue doesn't come from wpForo or Wordfence. And it the alert comes IN YOUR BROWSER and not in the page.

wpForo and Wordfence work nice. No issues.

Posts: 21
Topic starter
(@cindy_)
Eminent Member
Joined: 1 year ago

Hello, 

Yes I have both for testing it ^^

Ok, yet it's strange because when I disable Wordfence, I can create new users usually!

Robert
Posts: 10520
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @cindy_,

Yes this is Wordfence error, but this doesn't mean it conflicts with wpForo because we use Wordfence with wpForo in many websites. So this is just a configuration issue or some incompatibility with your hosting. In both cases, the issue doesn't have relation to wpForo. You should contact the Wordfence support. Here is another example of such issue: https://wordpress.org/support/topic/new-users-being-blocked/

Posts: 21
Topic starter
(@cindy_)
Eminent Member
Joined: 1 year ago

Hello,

Thanks for the link you send me, I disable Two-Factor and CAPTCHA in Wordfence, and now new registration is working, with Wordfence on 😉

1 Reply
selsebil
(@selsebil)
Joined: 3 years ago

Estimable Member
Posts: 88

@cindy_ You don't need to disable two factor authentication. Just members using two factor must log in through wordpress login page instead of wpforo page. I do in this way. If you try to login via wpforo login page you see this warning.