Notifications
Clear all

[Solved] Clicking "Logout" directs to wrong url.

13 Posts
2 Users
1 Reactions
1,890 Views
Posts: 18
Topic starter
(@uckun)
Eminent Member
Joined: 5 years ago

Hi, when I click "logout", which is already adjusted as "/%wpforo-logout%/", the user logs our but it goes to a "404 Not Found" page because the url it directs is like this: 

https://mysite.com/community/%20https:/mysite.com/   

So I see a "404 Not found" page. Ok, I still log out but I need to go to a proper page whhen I logout. Where can the logout final landing page be adjusted? Can I put a custom page for logout? I couldn't solve this problem. 

12 Replies
Sofy
Posts: 4419
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @uckun

We'll need your forum URL to check the issue. 

11 Replies
(@uckun)
Joined: 5 years ago

Eminent Member
Posts: 18

@sofy

"KAYDOL" means "register" in the main menu.

"Giris Yap" means "Login".

After you login, "Çıkış Yap" appears in the menu, which means "Log Out" Click the "Çıkış Yap" to lpg out and you'll see the issue. 

(@uckun)
Joined: 5 years ago

Eminent Member
Posts: 18

@sofy

Hi, I sent you the URL four days ago as your requested but didn't hear from you? When will you look at it? 

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4419

@uckun

yes, I see the issue. I've contacted the developers and asked them about the issue and currently, I'm waiting for a response from them. I'll update this topic once I get a response from them. 

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4419

@uckun,

Please change the role of the user with the username to admin to allow the developers to check the issue and provide some solution for you.

(@uckun)
Joined: 5 years ago

Eminent Member
Posts: 18

@sofy

Ok, done. You can login as admin now. Pls let me know when you fix it.

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4419

@uckun

please watch the video below. Somehow we're not allowed to log in to your forum via the password we'd set before. 

Please generate a new password and leave it here. I've set the topic private.

(@uckun)
Joined: 5 years ago

Eminent Member
Posts: 18

@sofy

I can't see the link content you sent because "flash" contents don't work in my chrome browser and the link you sent is adobe flash content. But anyway, here's your password: ********

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4419

@uckun,

The issue comes from the "Uncanny Toolkit" plugin you're using. You should either deactivate the plugin or find a way to right configure the plugin. I'm not familiar with the plugin settings and cannot help you to configure it. However I've found the settings (see screenshot) that may help you to figure out how to solve the issue. 

Please don't forget to delete the caches before checking. 

BTW I've removed the password and login from the posts and set the topic public. In case if other users get this kind of issue the topic will help them to solve it.

(@uckun)
Joined: 5 years ago

Eminent Member
Posts: 18

@sofy

Hi, ok, I'll check it. By the way, I'll be glad if you also remove my website URL from the post as well, if you decided to make this support conversation public. (And also please blur the url in the picture of my back end which you attached please)

Sofy
 Sofy
Admin
(@sofy)
Joined: 6 years ago

Support Team
Posts: 4419

Done it 👍 @uckun 

(@uckun)
Joined: 5 years ago

Eminent Member
Posts: 18

@sofy

Thank you.. That helped... I entered the "Log In/Log Out Redirects" settings as seen in the pic you sent, and then removed the link written at "Logout Redirect" section in the settings of the plugin. Then celared the cache. This solved the problem. Thanks for your assistance.