Forum doesn’t appea...
 
Notifications
Clear all

[Solved] Forum doesn’t appear on mobile site

4 Posts
2 Users
0 Likes
1,501 Views
Posts: 3
Topic starter
(@fluidspin)
Active Member
Joined: 5 years ago

I’m using Wordpress and have wpForo forum as a plug-in. All was well until last week when I noticed that the forum doesn’t appear on the mobile site like on my iPad or iphone. But it appears just fine in the MacBook’s safari website. When I tried the customising section in Wordpress, I notice that when I switch to mobile appearance mode, the forum doesn’t appear. But on the full website it appears. I have tried to make sure Page URL and Forum URL are the same. But still can’t figure it out. 

3 Replies
Sofy
Posts: 4114
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @fluidspin,

The issue comes from your current active theme and has no any relation to wpForo. On the mobile screen, it adds {display: none;} CSS rule, thus the forum doesn't show. 

 

Please navigate to Dashboard > Forums > Settings > Styles admin page, put the following CSS code in "Custom CSS Code", textarea, save it, delete all caches, and check again. 

@media (max-width: 768px){
.fl-visible-desktop, .fl-visible-desktop-medium, .fl-visible-medium, .fl-col-group .fl-visible-desktop.fl-col, .fl-col-group .fl-visible-desktop-medium.fl-col, .fl-col-group .fl-visible-medium.fl-col {
display: block !important;
}
}
1 Reply
(@fluidspin)
Joined: 5 years ago

Active Member
Posts: 3
Posted by: Sofy

Hi @fluidspin,

The issue comes from your current active theme and has no any relation to wpForo. On the mobile screen, it adds {display: none;} CSS rule, thus the forum doesn't show. 

 

Please navigate to Dashboard > Forums > Settings > Styles admin page, put the following CSS code in "Custom CSS Code", textarea, save it, delete all caches, and check again. 

@media (max-width: 768px){
.fl-visible-desktop, .fl-visible-desktop-medium, .fl-visible-medium, .fl-col-group .fl-visible-desktop.fl-col, .fl-col-group .fl-visible-desktop-medium.fl-col, .fl-col-group .fl-visible-medium.fl-col {
display: block !important;
}
}

Hi Sofy,

I tried your method above but somehow it didn't work. But I noticed there was this "Additional CSS" field in my Wordpress customiser site. So I pasted the code you gave me there and now it works!

Really appreciate your help!

Posts: 3
Topic starter
(@fluidspin)
Active Member
Joined: 5 years ago

Thank you! Will try it out tomorrow when I can.