Notifications
Clear all

[Solved] Spam with Akismet and RECAPCHA activated

18 Posts
6 Users
8 Reactions
4,611 Views
Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

I'm using JUST The Shield plugin for all security / spam / fake robots registrations. No Akismet or the unfriendly recaptcha.

Works for me great.

Posts: 73
Topic starter
(@srtalop)
Estimable Member
Joined: 6 years ago

Thanks a lot @verek, @yossik and @anonymous20, so far I will try all your options. Have a nice day.

7 Replies
(@srtalop)
Joined: 6 years ago

Estimable Member
Posts: 73

Just as an update, I tried the IP country blocker and spam got reduced, however still 20 to 30 fake users per day. I tried the Shield and, still spam. Will keep on desperately trying...

(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602
Posted by: srtalop

Just as an update, I tried the IP country blocker and spam got reduced, however still 20 to 30 fake users per day. I tried the Shield and, still spam. Will keep on desperately trying...

If those fakes are bots, the Shield definitely IS blocking them. There are TONES of options in the Shield plugin, did you enable them ?

 

(@srtalop)
Joined: 6 years ago

Estimable Member
Posts: 73

probably not, I am learning the plugin options as we speak. Any suggestions?

(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602

I will try. I will ONLY cover the login options since there is a LOT to configure in the whole plugin's options. The rest (firewall etc etc is something YOU must invest some time to tune).

1. Disable for a while all recaptcha and akismet.

2. In The Shield / Login Guard options enable "Protect WP Login From Automated Login Attempts By Bots"

That option will put a "I'm Human" checkbox to login/register.

For now do not do anything else. Update us here.

If the above doesn't work for you, there is a option in Login Guard options to Enable Google Recaptcha. Try that AFTER the above fails.

Also it could help if you want and can post a url of your site.

(@srtalop)
Joined: 6 years ago

Estimable Member
Posts: 73

Thanks, the thing is that this action adds the "I´m human" option to the login form, but not to the forum register form. Please see attachment. *spam users are forum members.

(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602
Posted by: srtalop

Thanks, the thing is that this action adds the "I´m human" option to the login form, but not to the forum register form. Please see attachment. *spam users are forum members.

For me it works just fine. Maybe a theme issue ?

 

(@anonymous20)
Joined: 8 years ago

Noble Member
Posts: 1602
Posted by: srtalop

Just as an update, I tried the IP country blocker and spam got reduced, however still 20 to 30 fake users per day. I tried the Shield and, still spam. Will keep on desperately trying...

Also Spam where ? Comments ? Blog Posts ? Forum Posts ?

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

New registrations also works fine.

 

1 Reply
(@srtalop)
Joined: 6 years ago

Estimable Member
Posts: 73

Hi @anonymous20, sorry for the very late response. Everything is working fine now. No spam, no bots and the "I am a human" option is active in all forms.

Thanks for your kind help.

Page 2 / 2