Private message plu...
 
Notifications
Clear all

wpForo 1.x.x Private message plugin not working

22 Posts
3 Users
0 Likes
740 Views
kojo
Posts: 20
 kojo
Topic starter
(@kojo)
Eminent Member
Joined: 9 months ago

The private message plugin shows the following issue when creating a message.

https://share.getcloudapp.com/d5u9zOXw

also imported a group of users. However, the import date shows as:-

https://share.getcloudapp.com/P8u1WQzOkojo

Can it be manually corrected?

wpForo Version
1.9.9.1
WordPress Version
5.9.2
7.4
10.4.22
Topic Tags
21 Replies
kojo
Posts: 20
 kojo
Topic starter
(@kojo)
Eminent Member
Joined: 9 months ago

Rather than open a new post. can you point me to the setting to change the 

"You are not allowed to write a message yet"

So that new users and moderators can send private messages.

I have checked all under 'Forum Access'

Reply
kojo
Posts: 20
 kojo
Topic starter
(@kojo)
Eminent Member
Joined: 9 months ago

Can close this thread, the error shown above, only appears when logged in as admin. and found the "You are not allowed to write a message yet" under addons tab.

Reply
kojo
Posts: 20
 kojo
Topic starter
(@kojo)
Eminent Member
Joined: 9 months ago

I am totally confused, according to the settings Admin, should be able to send a private messages. can you please confirm

Reply
8 Replies
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@kojo,

Go to Usergroups > Admin and check Front - Can write PM option

Reply
kojo
 kojo
(@kojo)
Joined: 9 months ago

Eminent Member
Posts: 20

@chris Yes, I went through every setting and It's checked.
however, it just hangs

https://share.getcloudapp.com/d5u9zOXw

retested just now.

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@kojo,

It should be a JS error, in your website check browser Console Log there you should see a JS error.

Also provide us your Forum URL, we will check as well.

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@kojo,

Also mention we support here only wpForo plugin, not the addons

If you'll have other issues with the addons please create a new topic about that at https://gvectors.com/forum/wpforo-support/

Reply
kojo
 kojo
(@kojo)
Joined: 9 months ago

Eminent Member
Posts: 20

@chris

Hi, this is what I see in the console but I don't have a clue what it means.
---
JQMIGRATE: Migrate is installed, version 3.3.2
companion-bubble.js:1409 Uncaught (in promise) b.AssertionError
---
site url: https://kiswahiliforum.org/

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@kojo,

Find the plugin which is related to this JS error and deactivate it, after check the PM again, the infinite loading issue has to get solved.

Reply
kojo
 kojo
(@kojo)
Joined: 9 months ago

Eminent Member
Posts: 20

@chris 

I do not have many plugins on the site as it is primarily for the forum. I have deactivated all other plugins, and the issue is still present
These are the only active plugins.

see here: https://share.getcloudapp.com/RBun0lWq

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2405

@kojo,

After registration, I can't Log in your website, need to check from where come that JS error.

Reply
dimalifragis
Posts: 1830
(@dimalifragis)
Noble Member
Joined: 3 years ago

I think some caching is messing your site, Online Users is also not working.

 

 

Reply
6 Replies
kojo
 kojo
(@kojo)
Joined: 9 months ago

Eminent Member
Posts: 20

@dimalifragis  

I have removed all caching and, even turned server caching.

issue still present.

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1830
Posted by: @kojo

@dimalifragis  

I have removed all caching and, even turned server caching.

issue still present.

Please read carefully what i wrote. Not a caching issue but some Litespeed script.

SEE THE html source of YOUR page:

 

<script type="text/javascript">
			window.flatStyles = window.flatStyles || ''

			window.lightspeedOptimizeStylesheet = function () {
				const currentStylesheet = document.querySelector( '.tcb-lightspeed-style:not([data-ls-optimized])' )

 

Reply
kojo
 kojo
(@kojo)
Joined: 9 months ago

Eminent Member
Posts: 20

@dimalifragis 

The theme developer respond as follows

I checked your Project LightSpeed and i see that you were able to disable it already. -  https://share.getcloudapp.com/lluE49Wm

Please also note that our Project LightSpeed tool is for our Thrive files & script only and it doesn’t affect the files or code of your app or any 3rd party plugin.

If you experience issues with that app or 3rd party plugins, I would recommend you to contact their support or developer instead for assistance.
________

Following this responce:

I set the site to the default WordPress theme. and the error still persists as shown here:

https://share.getcloudapp.com/BluoNKpv

I found another thread in this forum with the same issue but that thread ended without a resolution.

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1830

@kojo Right. It seems i thought LightSpeed was LiteSpeed. Apologies.

What happens if you switch for a while to the default theme?

 

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1830

@kojo You may try the a WP standard debug procedure.

1. Switch to default theme.

2. Disable all plugins except wpForo and the addon.

3. Enable WP Debug to a log.

4. Disable for a while your CDN.

And as Chris posted above, there is a specific forum for addons, maybe they can help you more.

Reply
kojo
 kojo
(@kojo)
Joined: 9 months ago

Eminent Member
Posts: 20

@dimalifragis

I did not do the full list as described. but I did switch to a default theme. and the issue persisted.  I have raised the issue in the addons forum.

 

Reply
Page 1 / 2