Unread topics not g...
 
Notifications
Clear all

wpForo 1.x.x [Solved] Unread topics not going to first unread post

19 Posts
3 Users
2 Likes
2,093 Views
sazdoes
Posts: 49
Topic starter
(@sazdoes)
Eminent Member
Joined: 3 years ago
Posted by: @robert

Can you disable "Jump to First Unread Post with [new] Button in Topic Link" option in Dashboard > Forums > Settings > Features Tab and check it again?

And use the link for first unread?
-that doesnt work btw, it just goes to the topic without any post id.

sazdoes
Posts: 49
Topic starter
(@sazdoes)
Eminent Member
Joined: 3 years ago

The URL has a post-id, but no page-id.
I attached a screenshot.

And another screenshot. Url from new button can be seen in the bottom. The topic has 5 pages.

 

Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago
Posted by: @sazdoes

And use the link for first unread?

@sazdoes,

If you want to go to first unread post, please do this configuration in Forums > Settings > Features Tab and delete wpForo cache in Forums > Dashboard admin page:

  • Yes | Log Viewed Forums and Topics
  • Yes | Track Forum and Topic Current Viewers
  • Yes | Topic Links Jump to First Unread Post
  • No | Jump to First Unread Post with [new] Button in Topic Link

 

And don't care about the page ID. It doesn't need page ID, it'll redirect and open correct post in correct page with post-id only. Just make sure the red marked options are enabled and try to click the links of topics. You'll see that all works fine, and it goes to correct post with the correct page (even if the page number doesn't exist in the URL).

sazdoes
Posts: 49
Topic starter
(@sazdoes)
Eminent Member
Joined: 3 years ago

That's not using the new button? I actually wanted to give both options to users?

I tried the settings you suggested and it seems to work a little bit better. Not flawless, like 50% of the time. 😳 

1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

@sazdoes,

Then enable the "Jump to First Unread Post with [new] Button in Topic Link" option as well. And delete all caches.

Posted by: @sazdoes

I tried the settings you suggested and it seems to work a little bit better. Not flawless, like 50% of the time.

There is no 50% result for any options. All options works 100%. It depends on your checking. You're forgetting which topic has unread post which doesn't. Just click the [Mark all unread] button in the footer and check all new topics.

Make sure the topic are created by other users. Even if you're loggedin with other user the browser will keep information about the read topics, so the test should be real with real different user and different browser.

sazdoes
Posts: 49
Topic starter
(@sazdoes)
Eminent Member
Joined: 3 years ago

All my users are complaining about it, so it's not a local thing to me.

It's not working. At the moment, also not with the "new" setting added.
-Screendump attached-

In the meantime I set up a test environment with only WP and WPForo, nothing else (like peepso and bridge). We're testing that right now. So far so good, it works. But I need more posts and users to make it substantial. If it keeps on going well I'll slowly add plug-ins to find out if it's in there.

The point is, throughout our entire test phase this wasn't a problem at all. Then I went live and the problem popped up after several 1000 of posts and 100's of users.

I have to get this problem fixed, one way or the other. Users don't want to read because it takes them to many clicks.

 

Page 2 / 3