Unread topics not g...
 
Notifications
Clear all

wpForo 1.x.x [Solved] Unread topics not going to first unread post

19 Posts
3 Users
2 Likes
1,812 Views
sazdoes
Posts: 49
Topic starter
(@sazdoes)
Eminent Member
Joined: 2 years ago

I posted about this before, but it's still an issue and we have some more info about it.

We found out that it does work when the topic has one page, and when the first unread post is on the second page it doesn't work. The problem seems to be that the url to the first unread post doesn't get a "/paged/2/" with it. If you past this manually in the url, the problem is solved.
So, I thought, maybe this is something to work with? Or is this some setting I missed?

I must say this is a very important feature and I really hope it will work in the future.

18 Replies
Robert
Posts: 9707
Admin
(@robert)
Support Team
Joined: 6 years ago

Hi @sazdoes,

There is no such an issue on all our test websites. I think this is a site specific issue. Please try to click the "Mark all read" link in the forum footer and delete wpForo cache in Dashboard > Forums > Dashboard admin page and check it again.

Also, please provide more info:

1. Where is the link you're clicking to go to the latest unread post (widget, recent posts, forum list...)?

2. How have you set these options in Dashboard > Forums > Settings > Features tab:

  • Log Viewed Forums and Topics
  • Track Forum and Topic Current Viewers
  • Topic Links Jump to First Unread Post
  • Jump to First Unread Post with [new] Button in Topic Link

3. What forum layout you use for that topics?

4. Is this a private topic or a topic in a private forum?

sazdoes
Posts: 49
Topic starter
(@sazdoes)
Eminent Member
Joined: 2 years ago

@Robert

Sorry for my late reply, something came up. I tried to answer the questions for the best. Let me know if I need to change anything. I'd really like to sort this issue.

Posted by: @robert

1. Where is the link you're clicking to go to the latest unread post (widget, recent posts, forum list...)?

2. How have you set these options in Dashboard > Forums > Settings > Features tab:

  • Log Viewed Forums and Topics
  • Track Forum and Topic Current Viewers
  • Topic Links Jump to First Unread Post
  • Jump to First Unread Post with [new] Button in Topic Link

3. What forum layout you use for that topics?

4. Is this a private topic or a topic in a private forum?

1. It comes from the menu as provided by wpforo. So the "unread topics" menu item.

2.

  • Log Viewed Forums and Topics
    -> YES
  • Track Forum and Topic Current Viewers
    ->YES
  • Topic Links Jump to First Unread Post
    ->NO
  • Jump to First Unread Post with [new] Button in Topic Link
    ->YES

3. I use "Simplified" on all forums

4. No, it's public or for registered users. It doesn't make a difference. I very few topics marked as private. 

sazdoes
Posts: 49
Topic starter
(@sazdoes)
Eminent Member
Joined: 2 years ago

@Robert
Did you get a chance to look at this?

1 Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9707

@sazdoes,

That should be fixed with 1.9.4 version. Have you updated?

The /page/2/ issue should be fixed. Make sure you've deleted all caches after the update.

sazdoes
Posts: 49
Topic starter
(@sazdoes)
Eminent Member
Joined: 2 years ago
Posted by: @robert

Make sure you've deleted all caches after the update.

Just to be sure, what caches do you mean exactly? I used the button "delete all caches" (first on the dashboard).
-because just updating didn't fix the problem

1 Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9707

@sazdoes,

If you have some cache plugin, please delete that cache too.

Can you disable "Jump to First Unread Post with [new] Button in Topic Link" option in Dashboard > Forums > Settings > Features Tab and check it again?

 

 

Page 1 / 3
Share: