Reply box keeps loa...
 
Notifications
Clear all

wpForo 1.x.x Reply box keeps loading

16 Posts
4 Users
3 Likes
584 Views
VirtualProfitLife
Posts: 11
Topic starter
(@virtualprofitlife)
Active Member
Joined: 1 year ago

As many others have posted about this issue, I've run into the same thing with the reply box constantly loading. The TinyMCE editor is broken. I've searched the wpforo forums to try to find an answer to my problem, but nothing seems to work. I've disabled any optimization plugin I have, cleared cache and checked the PHP code in the footer of my theme. I'm using Colibri theme editor with their Tattoo Pro demo theme. Latest version of Wordpress as well as wpforo.

 

I would change themes, but I'm afraid of losing my current layout (new to Wordpress). Any help would be greatly appreciated. Here's the link to the forum I'm building for my brother https://www.whitehorserevelation.com/community.

 

Test user account is testdummy. Password is TestDummyPassword

15 Replies
VirtualProfitLife
Posts: 11
Topic starter
(@virtualprofitlife)
Active Member
Joined: 1 year ago

Attached is a screen shot.

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 6 years ago

Support Team
Posts: 9707

@virtualprofitlife,

This is a cache plugin issue. First, please purge all kind of cache and disable the W3 Total Cache plugin. Then go to forum front-end press Ctrl+F5 twice, then use a private/incognito session to check the result.

If the problem is fixed, then activate it back and try to find a way to exclude your forum from W3 Total Cache plugin. The forum page with all sub-pages /community/* should be excluded from your cache plugin. Here is the topic about that: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

BTW, if you cannot find a proper way to exclude the forum page with all sub-pages from your cache plugin, you should change the plugin to other plugins like WP Super Cache, this one has a good option to exclude the forum page, it's described in the same topic.

Reply
VirtualProfitLife
Posts: 11
Topic starter
(@virtualprofitlife)
Active Member
Joined: 1 year ago

Thank you for your reply.

It seems everything I try, nothing works. I've deactivated any kind of plugin that caches, installed WP Super Cache, cleared all caches, cleared browser history, viewed incognito. I'm not sure what I'm doing wrong.

Reply
5 Replies
dimalifragis
(@dimalifragis)
Joined: 2 years ago

Noble Member
Posts: 1636

@virtualprofitlife Ok, then follow the Standard WP debug procedure.

Switch to the default theme and test

Disable all plugins and test

Enable one by one the plugin and test

Enable WP DEBUG to a LOG and check what is in it

 

There is no other way.

Reply
VirtualProfitLife
(@virtualprofitlife)
Joined: 1 year ago

Active Member
Posts: 11

@dimalifragis Will I lose my current layout if I switched themes?

Reply
dimalifragis
(@dimalifragis)
Joined: 2 years ago

Noble Member
Posts: 1636

@virtualprofitlife I have no idea how your current theme/composer works. Usually you loose some widgets in areas.

Still, i don't know.

But this is a conflict with something.

Reply
VirtualProfitLife
(@virtualprofitlife)
Joined: 1 year ago

Active Member
Posts: 11

@dimalifragis I'm backing up my site now. Wish me luck!

Reply
VirtualProfitLife
(@virtualprofitlife)
Joined: 1 year ago

Active Member
Posts: 11

@dimalifragis It's my page builder plugin. I'm using Colibri Page Builder Pro and their Tattoo Pro demo theme. So it must be something in the theme.

Reply
VirtualProfitLife
Posts: 11
Topic starter
(@virtualprofitlife)
Active Member
Joined: 1 year ago

I'm back.. with the same issue. The developer of the theme I'm using logged into a network admin account I created for him and claims it's a plugin issue after all. Offered no help other than to tell me to come back here to have you guys help me troubleshoot it. I'm seriously behind schedule and about to move to another forum plugin. Not that wpForo is in the wrong here. But I just can't figure this out. Is there any other way to figure this out besides what I've already tried?

Reply
4 Replies
dimalifragis
(@dimalifragis)
Joined: 2 years ago

Noble Member
Posts: 1636

@virtualprofitlife I use Neve theme and 31 plugins. Along with wpForo. Not a single issue.

And some 30.000+ installations use wpForo (according to Wordpress.org), so you understand that this is NOT an issue with wpForo.

What is F12 (your browser console) telling you? Is there any red error during the issue?

(checking Colibri Page Builder Wordpress.org forums, all i see is critical error issues and reports.....)

Reply
VirtualProfitLife
(@virtualprofitlife)
Joined: 1 year ago

Active Member
Posts: 11

@dimalifragis I can't find any issues on Chrome. I emailed them back and told them to log back in and check again. They owe me the support because I actually paid for their editor. I'll report back and let you know how it goes.

Reply
Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 866

@virtualprofitlife,

your problem is directly connected to the TinyMCE editor JS file. For some reason, the rich editor JS fine is not loaded. It’s disabled. There is an option called "Disable the visual editor when writing" in each user Dashboard > Users > Edit Profile admin page. It seems this option is enabled for all users, or somewhere in your theme the Rich Editor is disabled for front-end use. You should find the plugin which stops loading TinyMCE rich editor on front-end, or you should check all options of your theme to make sure it doesn't have such an option. but the first, you should edit user profile in dashboard and make sure the "Disable the visual editor when writing" option is not enabled.

Reply
VirtualProfitLife
(@virtualprofitlife)
Joined: 1 year ago

Active Member
Posts: 11

@Martin That option isn't enabled.

 

But I did download an advanced editor tool for TinyMCE, and one of the options is greyed out because it says the editor style sheet is missing. I'm guessing anyway. Here's the message.

 

Disabled: A stylesheet file named editor-style.css was not added by your theme.

Reply
VirtualProfitLife
Posts: 11
Topic starter
(@virtualprofitlife)
Active Member
Joined: 1 year ago

For anyone using the Colibri Page Builder, ColibriWP figured out my problem.

wpForo is not meant to be edited in Colibri Page Builder. I’m not sure about any other page builders. But in my case, it was Colibri.

I wasn’t trying to style the forum, but edit the padding of the forum wrapper in Colibri because there were gaps I wanted to fill, as well as get rid of the hero header. I just wanted the navigation bar and the forum.

When the /community/ directory is edited in CPB, it breaks the “Leave a reply” TinyMCE. I’m not sure how they fixed it or why it breaks the JavaScript, but I’m going to ask them how to fix it if I ever need to edit the page again to add a widget. 

Reply
Page 1 / 2
Share: