Notifications
Clear all

UM Menus with Wp-Foro don’t work.

6 Posts
2 Users
0 Likes
157 Views
slash018
Posts: 3
Topic starter
(@slash018)
Active Member
Joined: 3 months ago

Hello Team,

I’m using Ultimate Member for login and register along with conditional menus (for logged in & logged out users), However i’ve added the UM login & reg URLs to redirect in WP-Foro settings. But the problem is the redirections and conditional menus don’t have any effect. Even when users are logged in the conditional menu tabs for logged out users are visible, and also the Wp-Foro forums don’t seems to recognise the user has been registered.

Although i don’t always face this issue, and few times everything works as expected. but not every-time..

Kindly please help me on this. Thank you!

My Forum link :  https://openlib.io/

Regards,

wpForo Version
2.0.9
WordPress Version
6.0.3
5 Replies
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

@slash018,

Please take a screenshot of the settings, where we can see the URLs you've set for custom Login and Registration. This is the correct way to change wpForo Login and Registration pages:

 

Reply
4 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

Also, please enable the User Registration option. I see it's disabled in your screenshot. It doesn't have any relation to the page URL of the registration menu.

Reply
slash018
(@slash018)
Joined: 3 months ago

Active Member
Posts: 3

Hello @robert, Thanks for your message.. 

I've added the image in this path, since i was not able to upload multiple images. 

https://ibb.co/0ZWB0ny
https://ibb.co/0yPVd49  
https://ibb.co/bP76M4n  

I also noticed the Custom Redirection URLs will is reset to blank after i've submitted it. Please do let me know if it's okay.? 

I've now enabled User Registration options, will let u know if i see any fixes.. 

Please do kindly help me on this. Thanks!

Regards,

 

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9966

@slash018,

1. Do not use full URLs for Custom Authorization URLs, you should use paths:

  • /login/
  • /register/

Here is the doc: https://wpforo.com/docs/wpforo-v2/settings/login-registration/#custom-authorization-urls

And you should make sure the /login/ and /register/ pages exists. That pages should be provided by other plugins, or they should exist in Dashboard > Pages admin page. You can not set a path without existence of that pages.

2. Remove the Custom Redirection URLs. They'll not work because the login pages are no longer the wpForo pages. wpForo cannot do any redirection if the login and registration pages are not provided by wpForo. If you use custom login and registration pages then you should handle it yourself or contact the custom login/registration page builder plugin support.

Reply
slash018
(@slash018)
Joined: 3 months ago

Active Member
Posts: 3

@robert , Thanks for your reply.

As you suggested i've now removed the full URL for Custom Authorization URLs and added just the page for login & register which is done using Ultimate Member plugin. I've also removed the Custom Redirection URL's and left it blank. but still i'm facing same issue.

I'm using W3 - Total Cache plugin for handling the cache for my site. But i'm seeing an error as "wpForo and «W3 Total Cache» conflict - Action Required!". Although i've excluded all the forums pages as suggested in the error message within W3 - Total Cache plugin, I'm still seeing the error. 

Another issue is WpForo is unable to recognise if the User is logged in or not. I've set the UM's conditional menus (to be visible only for logged out users) for login & register menus. but still it don't have any effect, even logged in users are able to see login & register menus. 

Please find, i've added imgs for reference. 

https://ibb.co/M7MQpfx  
https://ibb.co/K79jf7D  

Please, kindly help me on this. 

Regards,

 

 

 

Reply