Notifications
Clear all

[Closed] Page Title issue with WPForo widget

29 Posts
5 Users
0 Likes
1,143 Views
Posts: 126
Topic starter
(@cotner)
Estimable Member
Joined: 2 years ago

I am trying to troubleshoot an issue I am having with the Recent Posts widget. [wpforo item="recent"]

When I use that shortcode on a page, it changes the Page Title of the page to "Recent Posts - Gopher Puck Live" instead of what I have set within Yoast which would be "GPL - Portal". In fact, I installed Yoast this morning in hopes to fix this problem but I was unable to get it done.

 

Any thoughts on how I can fix this issue?

 

 

28 Replies
Posts: 1
(@shankard97)
New Member
Joined: 1 year ago

Same issues.

Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @cotner,

That is not related to wpForo, in all your pages that Title(HTML alt attribute) is the same.

dimalifragis
Posts: 2568
(@dimalifragis)
Famed Member
Joined: 4 years ago

Disable Auto optimize. Not needed in 2022 and can create issues.

Posts: 126
Topic starter
(@cotner)
Estimable Member
Joined: 2 years ago

I was able to fix the problem by turning off the WPForo SEO.. "Enable Meta Title" and "Enable Meta Tags".

 

So it was a WPForo issue. It was inserting it's own meta tags on pages that contain the widget no matter what the site settings were.

1 Reply
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2568
Posted by: @cotner

I was able to fix the problem by turning off the WPForo SEO.. "Enable Meta Title" and "Enable Meta Tags".

 

So it was a WPForo issue. It was inserting it's own meta tags on pages that contain the widget no matter what the site settings were.

Turning off wpForo inbuild SEO is now ruining your SEO.

ALL your topics now have the same canonical url, same title and descriptions are probably off. Check it for yourself.

Page 1 / 3