Notifications
Clear all

wpForo 1.x.x [Closed] 5 sec. to reply, is it normal?

10 Posts
4 Users
2 Reactions
828 Views
Posts: 109
Topic starter
(@beyondforce)
Estimable Member
Joined: 5 years ago

Hey guys,

I'm really happy with my current forum set up. But I wondered if 5 sec. considered to be a normal time from the moment you click on the replay until the reply is submitted? During that time I see the wheel in the top right corner spinning and spinning, which doesn't happen in this forum at all.

I'll appreciate your feedback.

Ben.

9 Replies
Posts: 988
Moderator
(@martin)
Support Team
Joined: 8 years ago

Hi @beyondforce,

This is a delay from email sending process. When you reply wpForo sends email notification to all users who are subscribed to that forum, to that topic and to the user who is mentioned in your reply. So you search the problem in email sending solutions you have. Maybe your hosting server email server doesn't work fast or you have a plugin which affects the email sending process speed. Or maybe the email sending functions doesn't work at all on your hosting service. Please navigate to Dashboard > Forums > Tools > Debug > Problems & Issues Tab and check the errors. 

6 Replies
(@beyondforce)
Joined: 5 years ago

Estimable Member
Posts: 109

@martin

I'm communicating with one person!

I'm using the WP Mail SMTP plugin so the mails will be sent as fast as possible and I'm using the Gmail mailer to speed up the process and to prevent the mails to end up in the spam folder.

So what you are saying is that it might be the plugin that slows down the reply process?

 

 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10525

@beyondforce,

Martin is correct. In 99% case the email sending functions cause such delay. Could you please disable the WP Mail SMTP plugin and test it again? Just for debugging purpose.

 

(@beyondforce)
Joined: 5 years ago

Estimable Member
Posts: 109

@robert

Ok, I'll try that and get back to you if there aren't any positive changes.

But I also noticed that if I'm not using the Gmail mailer, my emails get a notification when you open them that it could be a spam or wors ends up in the spam folder. I have also checked and my domain is not blocked or band anywhere.

Thanks.

 

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10525

@beyondforce,

Also, I'd recommend disable other plugins and test again. This maybe other plugins conflict too. And let me know how many users you have in forum. Maybe you have hundreds of subscribers to the forum where you're posting.

 

(@beyondforce)
Joined: 5 years ago

Estimable Member
Posts: 109

@robert

My forum is quite new, not so much activity yet. But I want to figure out how to improve on the reply delay before I'm inviting more people.

I'm running the test on a test site, which is identical to the production. I have disabled the WP Mail SMTP plugin and it didn't get better.

I'll try to disable most of the plugins and see it make a difference.

 

(@beyondforce)
Joined: 5 years ago

Estimable Member
Posts: 109

@robert

So, I have disabled most of the plugins and I didn't notice any difference.

A normal Text reply takes about 3 sec. and a reply with a 40mb video file takes about 10-12 sec. Would you classify those timings as normal?

In this forum, people are going to attach lots of files in general inclouding videos, so I want to do everything I can to make sure that replying won't take too long time. 

 

Posts: 1602
(@anonymous20)
Noble Member
Joined: 8 years ago

I don't see a reply with a video or not to have anything to do with emails out (smtp). It is the same notification.

But emails out could slow you down. Also gmail for smtp? Not a good idea.

A url could help but this seems more a hosting/setup problem, than wpForo or Wordpress.

UNLESS you have some fatal error and you do not know it. Enable Wordpress debug to a log and check.

Edit: if your site is: https://te**eg.com then you have a huge ammount of JS and other errors. Press F12 and check and fix them. _could_ be the source of your problems (still enable debug to a log).

Robert
Posts: 10525
Admin
(@robert)
Support Team
Joined: 8 years ago

Something is wrong on your website or in hosting service. This is not wpForo problem for sure and in 99% it's still email sending issue. Disabling most of the plugins is not a solution. It would be more helpful if you disable all other plugins. Please let us know this info too:

1. What hosting service you use? Please provide PHP and MySQL version.

2. Please navigate to Dashboard > Forums > Tools > Debug and check Server, Tables and Error & Issues Tabs, if you see any problem please let us know.

3. Check error.log files in file system on root directory of your website and in /wp-admin/ directory.

4. Please leave your forum URL