Notifications
Clear all

wpForo 1.x.x All My Posts Display 404 Page Not Found After I Moved Forum to Homepage

17 Posts
5 Users
3 Likes
515 Views
ediko
Posts: 53
Topic starter
(@ediko)
Trusted Member
Joined: 2 years ago

Hello guys,

All my posts now displays "404 Page Not Found" After i moved my forum to the homepage.

Please i need to resolve this.

Topic Tags
16 Replies
Martin
Posts: 868
Moderator
(@martin)
Support Team
Joined: 6 years ago

@ediko,

I hope you've not enabled the "Turn WordPress to wpForo" option. If so, please disable it and read the description of that option before  enabling it. Never use things that you don't know.

If this is not that case, then explain how have you put your forum on home page.

Have you tried to disable all caches?

Also, have you deleted wpForo cache in Dashboard > Forums > Dashboard admin page?

Reply
Macky
Posts: 977
(@percysgrowroom)
Noble Member
Joined: 4 years ago

Something like this happened to me. It was something with the timing of when the forum was made, to when the page was made. 

The forum page number was somewhere, and you have to make sure that is assigned to the correct page number. 

Man it was ages ago, and i forget the finer details sorry. 

go to the top bar and hover over "forum dashboard"

go to "settings" and clik that

If you scroll down a little, and see under the box turn forum into front page, there will be something that says "forum page id" and it will have the page number next to it. 

That needs to be changed to be on the right page you have recently made..... but im not sure how to do it lol 

 

Goood luck man

Reply
ediko
Posts: 53
Topic starter
(@ediko)
Trusted Member
Joined: 2 years ago

@martin Okay, i think the problem was from the theme i used. The theme showed other Mal-functions.

However i still have another problem.

my forum was initially at thebendelite.com/forum before i moved it to thebendelite.com

(Please the site is currently locked under construction for now for personal reason)

my old forum topics and new topics still carry the permalinks of thebendelite.com/forum/*****.

For instance i just made a post now this is the link it created https://thebendelite.com/forum/front-page-topics/new-post/.

How can i set it to only homepage url / category / post title

This is a typical example of what i need from a wpforo forum site https://thekojiforum.com/seo/easy-to-rank-keywords/

Thanks.

Cc @robert, @tutrix

Reply
13 Replies
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@ediko,

This is the working logic of wpForo and of all WordPress plugins which brings new content to front-end. There should be a base path like /forum/ for forum plugins or /events/ for Events plugin or /products/ for Ecommerce plugins like WooCommerc and so on... there is no way to remove that path. Because there is no way to let plugins know that the current URL is related to a forum or an event or a product, this is the only indicator and it cannot be removed.

Reply
ediko
(@ediko)
Joined: 2 years ago

Trusted Member
Posts: 53

@robert This forum here is a WPForo forum.

It is on the hompage and doesn't have a base path like /forum as you said.

https://thekojiforum.com/seo/easy-to-rank-keywords/

How did they achieve that?

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1828

@ediko REMOVE totally this:

Generated by Endurance Page Cache

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@ediko,

That because this forum has turned on the "Turn WordPress to wpForo" option. This option should be enabled in case you don't have other pages, posts or plugins on front-end, just read the description of this option before using it. So if you don't turn your WordPress to frum then you will have /forum/ prefix. There is no other solution. I've already explained it why.

Reply
ediko
(@ediko)
Joined: 2 years ago

Trusted Member
Posts: 53

@robert Okay Noted, if i use the option "Turn WordPress to wpForo"

can i still turn off the option with any complication?

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@ediko,

Yes, you can. Just read attentive, the option description. All non-forum page URLs should be inserted in the "Exclude pages" texarea, it'll be opened once the option is enabled.

Reply
ediko
(@ediko)
Joined: 2 years ago

Trusted Member
Posts: 53

@robert Greetings.

I am creating another WPforo and the option to "Turn WordPress to wpForo" is no longer available in the general settings. I've also search elsewhere and it's not there.

Please tell me what to do

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1828

@ediko SEARCHING is good.

It is located in BOARDS at the end.

Reply
ediko
(@ediko)
Joined: 2 years ago

Trusted Member
Posts: 53

@dimalifragis Thanks for your prompt response, I searched but couldn't find the answer and also the solution is quite different from what I knew last year.

Kindly assist for the requests below:

After using "Turn WordPress to wpForo" the forum is no longer responsive on different PC screen sizes.

Thanks

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1828

@ediko 

First this:

<!-- Page generated by LiteSpeed Cache 5.3 on 2022-11-09 11:13:08 -->

 

must be removed. Totally. NO caching for wpForo. wpForo has its own caching.

Checking your site, i get:

Error: your account is still pending.

Not sure what this is, since i didn't made any account, just visited the home page.

And i don't see any issue regarding being responsive.

(edit: i see that i have already posted to you to remove caching, but apparently you didn't. You just replaced endurance cache with litespeed cache)

 

Reply
ediko
(@ediko)
Joined: 2 years ago

Trusted Member
Posts: 53

@dimalifragis I have not posted the site I am working on yet on this platform. The site you visited was a site I earlier used as a reference. For personal reasons the site is still under construction or can I give you my admin login to see it?

See the screenshot attached.

Thanks

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1828

@ediko ok, then i can't help more.

When ready you could post a link to check.

Reply
ediko
(@ediko)
Joined: 2 years ago

Trusted Member
Posts: 53

@dimalifragis I'll quote you by tomorrow when the site is open.

Sorry for the many questions, how can I add a logo to my forum as

seen on this link https://thekojiforum.com/

Do I need to purchase the "Ads Manager Add-on" to do that?

Thanks for your response.

Reply