Notifications
Clear all

[Solved] auto update completely decimated forum

10 Posts
3 Users
0 Likes
137 Views
st0nehead_ss
Posts: 32
Topic starter
(@st0nehead_ss)
Eminent Member
Joined: 8 months ago

auto update of wp-foro complketely decimated my forum...back end can still see there are 18 forums, x posts etc, none of which now show, also the formatting is all lost.
ive seen the sticky thread on this, however rolling back to backup before auto-update had no effect on the forum side of things, nor did re-activating the old theme...

first pic is old forum design, which seems lost...?

9 Replies
st0nehead_ss
Posts: 32
Topic starter
(@st0nehead_ss)
Eminent Member
Joined: 8 months ago

here is how it looks now...if i activate dark theme...but more recently nothing at all shows up in forums...ive read the sticky but cant seem to find solution

st0nehead_ss
Posts: 32
Topic starter
(@st0nehead_ss)
Eminent Member
Joined: 8 months ago

here is now how it looks...

st0nehead_ss
Posts: 32
Topic starter
(@st0nehead_ss)
Eminent Member
Joined: 8 months ago
6 Replies
RealAct
(@realact)
Joined: 4 years ago

Estimable Member
Posts: 160

@st0nehead_ss If I understand you correctly, you have attempted to downgrade because the update went wrong.

What happens when you deactivate all addons and leave only the forum core? If you restored from an old database, did you delete the 2.0 WPForo files and put back the 1.X version? Old database backup from the 1.X version will not work with the 2.0 version of the forum software.

That theme that shows up is the 2022 theme, which comes with WPForo 2.0 version. So it seems you didn't downgrade properly or have a weird mix going on there.

 

st0nehead_ss
(@st0nehead_ss)
Joined: 8 months ago

Eminent Member
Posts: 32

@realact thanks, I just used backup tool to restore older version of site, maybe the plugin v2 remains.  I guess I need to delete the V2 plugin and reinstall v1?

 

I am not a dev, so forgive me for not being good with this stuff - but where do I delete the V2 files, and how do I replace V2 with v1 again?

st0nehead_ss
(@st0nehead_ss)
Joined: 8 months ago

Eminent Member
Posts: 32

i am looking at the help topics, it seems i need to delete v2 (i have no addons as far as i know) - then roll back to 1st AUG backup of WP site, then install the v1.9 plugin again

 

i guess then i'll have to rebuild the styling though??

 

any help appreciated, even if its upgrading and getting my styling back

Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 866

@st0nehead_ss,

It's not a good idea to roll back. It's easy to keep the v2. The problem is in your forum page, I don't see why your forum URL is /community-2/ .

So lets fix the forum issues then you'll be able to switch to the classic theme if you want and all will be ok. I hope you've not deleted data manually. If you didn't then all is there and all are ready to work with v2. Please send the admin login details to support[at]gvectors.com email address. We'll check and fix your issues.

st0nehead_ss
(@st0nehead_ss)
Joined: 8 months ago

Eminent Member
Posts: 32

@martin thanks, i'll do that now

 

Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 866

@st0nehead_ss,

Ok your forum is here and works very well:

https://livingsystems.health/forum/

it currently uses the classic theme but I strongly recommend switch to the new 2022 theme as soon as you can. The classic theme is deprecated and will not be supported soon. You can switch themes in Dashboard > wpForo > Themes admin page.

You can change your forum layouts if you want, here are the four layouts of the 2022 theme: https://wpforo.com/docs/wpforo-v2/categories-and-forums/forum-layouts/  

The issue was in boards. Somehow you didn't have board with ID=0 in Dashboard > wpForo > Boards admin page. There was only a board with ID=2 and this was a new empty board. wpForo requires the first board (ID=0) which is the main board with all your forum data. So we just changed the default board ID from 2 to 0 and all works now. All your custom css can be found in wpForo > Colors and Styles admin page.

Share: