Notifications
Clear all

wpForo 1.x.x [Solved] Being able to see the replies to my private topic.

12 Posts
3 Users
3 Likes
1,176 Views
JorgeW
Posts: 68
Topic starter
(@jorgew)
Trusted Member
Joined: 4 years ago

Hi SUPPORT,

If I want to post a topic that should be read only by a moderator, I need to post it as a Private Topic. This way, post will be notified by email only to a moderator and will stay private between me and the moderator.

When the moderator posts a reply to this topic, I receive (and only me) an email notification. When I go to the topic –which has been kept private– I can "read" that it has a reply but the reply is not displayed (see attached image).

The only way I can see/read the reply (so far) in a semi-private way is doing the following steps:

  1. - make the topic temporarily Public (which I would rather avoid)
  2. - immediately reload browser tab (this makes the reply viewable)
  3. - immediately make it Private once again. (reply stays visible)
  4. - if I need to, I can reply to moderator's reply with no problem.

The question now is this:

Is this behavior the "normal" one?

Isn't there a way that I can keep the topic always Private and still view and reply all replies to it?

 

Jorge

wpForo Version
1.6.1
WordPress Version
4.9.18
7.4.26
5.7.36
11 Replies
Chris
Posts: 1945
Admin
(@chris)
Support Team
Joined: 1 year ago

Hi @jorgew,

Please provide your forum URL.

2 Replies
JorgeW
(@jorgew)
Joined: 4 years ago

Trusted Member
Posts: 68

Hi @chris,

Sorry, I'm not allowed to do that, it's a private forum. 

What else can we do?

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1945

@jorgew,

I guess it's cache problem, please exclude wpForo from your cache plugin, also if you have minifying plugin exclude from it too.

Check This FAQ Topic About cache and cache plugins: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

JorgeW
Posts: 68
Topic starter
(@jorgew)
Trusted Member
Joined: 4 years ago

Hi @chris

After reading the FAQ topic, and as far as the forum is the main application in our site, I realized that I did not need the cache plugin (WP Super Cache Version 1.6.8) so I decided to deactivate it all the way.

- Then I cleared all my browser cookies and caches and deleted "All Caches" in wpForo dashboard. Started a new forum session and went to private topic: replies are being mentioned but NO replies were displayed.

- If I turn it public and reload tab, replies are displayed with no problem. But as soon as I set it to private and reload tab once again, replies disappear. 

---------------

Here is a list of all active plugins:

bbPress Version 2.5.14

Code Snippets Version 2.12.0

Contact Form 7 Version 4.3

Dynamic To Top Version 3.5.2

Easy WP SMTP Version 1.3.7

iframe Version 4.5

Limit Login Attempts Reloaded Version 2.8.1

TinyMCE Advanced Version 4.0.2

WP Crontrol Version 1.7.1

WP Login Timeout Settings Version 1.1.3

WP Super Cache (deactivated) Version 1.6.8

WP SVG Icons Version 3.2.3

wpForo Version 1.6.1

WPFront User Role Editor Version 2.14.1

YOP Poll Version 6.0.4

 

Jorge

1 Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1945

@jorgew,

Go to Dashboard > Forums > Settings > Forum Accesses, open Forum Access which is connected to your usergroup and check are the below checkboxes enabled:

  • Can set topic private
  • Can set own topic private
  • Can view private topic
Robert
Posts: 9715
Admin
(@robert)
Support Team
Joined: 7 years ago
Posted by: @jorgew

- If I turn it public and reload tab, replies are displayed with no problem. But as soon as I set it to private and reload tab once again, replies disappear. 

Please always specify the user usergroup who see or cannot see the replies.

 

If you're talking about the "Registered" Usergroup, then check the following:

1. Edit the forum of that private topic in Dashboard > Forums > Forums admin page, and check the Forum Accesses. Find the Forum Access name which is selected for Registered usergroup.

2. Edit the Forum Access in Dashboard > Settings > Forum Accesses Tab and make sure the following permissions are enabled, especially the blue marked ones:

  • Can view forum
  • Can enter forum
  • Can create topic
  • Can view topic
  • Can enter topic
  • Can post reply
  • Can reply to own topic
  • Can view replies
  • Can set own topic private
  • Can answer own question

 

If you're talking about the "Moderator" Usergroup, then check the following:

1. Again, edit the forum of that private topic in Dashboard > Forums > Forums admin page, and check the Forum Accesses. Find the Forum Access name which is selected for Registered usergroup.

2. Edit the Forum Access in Dashboard > Settings > Forum Accesses Tab and make sure the following permissions are enabled, especially the red marked ones:

  • Can view forum
  • Can enter forum
  • Can create topic
  • Can view topic
  • Can enter topic
  • Can post reply
  • Can reply to own topic
  • Can view replies
  • Can set topic private
  • Can set own topic private
  • Can view private topic
  • Can approve/unapprove content
2 Replies
JorgeW
(@jorgew)
Joined: 4 years ago

Trusted Member
Posts: 68

Thanks for your reply @chris @robert 

These are my actual settings for the registered members (the only way to access forum): (view attached image)

As you can see, "Can view private topic" is disabled.

The problem is that if I enable this option members will be able to view all private topics including of course its own.

There seems to be an option missing: "Can view own private topic" similar to other topic options:

 

  • Can set topic private
  • Can set own topic private

  • Can view private topic
  • Can view own private topic (option missing)

  • Can set topic solved
  • Can set own topic solved

 

This is precisely what I need: to set my own topic private and also to view ONLY my own topic replies.

Currently I can only view my own private TOPIC (which is fine) but not the moderator (private) REPLIES to it which I find kind of counter-intuitive.

Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1945

@jorgew,

Go to Forum Accesses, Edit "Full access", enable "Can view private topic", then go to Dashboard > Forums > Forums, edit the Categories and Forums, and select "Full access" for Admin in Forum Permissions field.

By this way all admins have "Full access" to the forum and can view private topics, other user who are not admins or their usergroup don't have full access in forums/categories won't be able to view private topics.

There is also moderator access in Forum accesses, so you can do the same for the moderators by enabling "Can view private topic" in Moderator access and set Moderator access in the Categories/Forums for Moderator Usergroup.

JorgeW
Posts: 68
Topic starter
(@jorgew)
Trusted Member
Joined: 4 years ago

@chris

The situation does not relate to admins or even moderators but to regular registered members

For example: in precisely this wpForo forum, if I –as a regular registered member, not as an admin nor a moderator– set this precise topic (which is my "own topic") to Private and reload browser, your replies as admin (or even as moderator I guess) do not vanish, just as if I set it back to Public and reloadThis is exactly the behavior I'm looking for for our own forum. 

I think this might be solved by including –as mentioned– the Can view own private topic option in the Forum Accesses settings, option which in my version (1.6.1) is missing.

An additional note: to update/upgrade wpForo is not an option for us for a few very needed customizations we made to 1.6.1.

1 Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 1945

@jorgew,

I'm sorry, but we don't support wpForo old Versions. There have been lots of updates on wpForo and bug fixes, so the issue you have, can be from wpForo old version or from the changes you have done on wpForo. The reason why I think like that, is that in wpForo 1.9.9.1 there are no issues with private topics, and the users who created a topic and set it to private, can see their topics and replies in it. And it doesn't matter what's their usergroup.

Page 1 / 2
Share: