Notifications
Clear all

wpForo 1.x.x Better spam fighting for new user profiles

6 Posts
4 Users
0 Likes
967 Views
Posts: 20
Topic starter
(@kraisor)
Eminent Member
Joined: 2 years ago

I get so many spam users registering on the site, they do not post anything but just activate the account, add a website link and add links in the about me section on their profile.

Here's a screenshot, so many of these.

I've been manually clearing these up, but it takes a lot time. It would be great if there was a feature that users had to be active for XX number of days or have XX number of posts before they can add a link in a profile field?

5 Replies
Robert
Posts: 9966
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @kraisor,

There is an option to make user posts approved after x number of posts. There is an option to allow users to add links and attach files after x number of posts. All Antispam options are located in Dashboard > Forums > Tools > Antispam Tab. But before checking these options please read this support topic and make sure you've done all steps of the spam protection: https://wpforo.com/community/faq/how-to-stop-spam/

Reply
dimalifragis
Posts: 1923
(@dimalifragis)
Noble Member
Joined: 3 years ago

@robert but this is NOT for profiles. The problem of the OP is different and we have it also. People registering, post nothing, just spam their profiles.

Reply
Posts: 20
Topic starter
(@kraisor)
Eminent Member
Joined: 2 years ago

@robert This is not for posts, this is for users who register and spam their profiles. I have recaptcha, Askimet, and everything else enabled. I even have Cloudflare security set to high for the forums.

Reply
1 Reply
Alvina
Moderator
(@alvina)
Joined: 3 years ago

Member
Posts: 1872
As a workaround, we may suggest you hide the website field via CSS.
You should use the following CSS code: 
#wpforo-wrap .wpf-table .wpf-field-name-site{
display: none !important;
}
The CSS codes should be added in the Dashboard > Fortums > Settings > Styles admin page, "Custom CSS Code" textarea.
Don't forget to delete all caches ad press CTRL+F5(twice) on the frontend before checking.
Reply
Posts: 20
Topic starter
(@kraisor)
Eminent Member
Joined: 2 years ago

They also leave links using html in the about section, so that wouldn't solve the problem.

Reply