Notifications
Clear all

wpForo 1.x.x Can't get email notifications working for members 🙁

17 Posts
2 Users
0 Likes
4,013 Views
rtev
Posts: 10
 rtev
Topic starter
(@rtev)
Active Member
Joined: 4 years ago

Despite these checks I can't get email notifications working for members.

The only thing that is not fine is this:

The balloon says Your subscription for this item can't be confirmed when I click the link in the subscription confirmation email. Must give someone here a hint I guess, but I'm out of inspiration.

My other checks:

  1. CHECK Before reporting this issue on support forums please make sure your server email sender works well. Make sure you got emails from your WordPress (on registration or on other cases…).
  2. CHECK Receiver is the same sender. Make sure the “From Email” (Forums > Settings > Email) is not the same subscriber email.
  3. CHECK If the “From Email” domain doesn’t have website domain name (e.g.: info@gmail.com, but website is example.com) it may tracked as spam, you should check in spam box.
  4. N/A: emails to admin are sent immediately Some hosting services, or some Antispam plugins try to cache emails and those are not being sent immediately. You should wait 1-30 min (e.g.: on some GoDaddy hosting plans you receive emails in 45 min).
  5. N/A If you’re using GMail Fetch services, go to Gmail Settings > Accounts and Import and click on “Check mail now” link to load all new comments from website email server.
  6. THIS WORKS FINE, BUT MEMBERS STILL DON'T GET NOTIFIED First email is the Subscription Confirmation Email, you should click on confirmation link and confirm your subscription to certain forum/topic. If you don’t get Subscription confirmation email and don’t confirm it you’ll not get future comments. Sometimes the confirmation email go to spam-box and user don’t check it. You should check in spam-box as well.
  7. TRIED EVERY POSSIBLE SCENARIO I CAN IMAGINE Test it as real as possible. You should use new IP, new emails and new accounts. The best way to ask your friend to post a reply with Subscription and Subscription Confirmation. Then reply him.
  8. CHECK Make sure you don’t reply to your topic or post.

Also,

  • I tried with and without Settings>Features>Enable Subscription Confirmation to YES as well as to NO
  • In the 'subscriptions' for members there is a list with the forums with subscriptions CHECKED

Anyone ideas?

Would love to get this working.

When there is a way to manually approve subscriptions per user by admin that would work for me also right now.

Thanks in advance!

Topic Tags
16 Replies
Robert
Posts: 9363
Admin
(@robert)
Support Team
Joined: 6 years ago

Hi @rtev,

Please navigate to Dashboard > Forums > Tools > Debug Tab > Tables sub-tab and leave a screenshot of your wp_wpforo_subscribes table, I need to make sure the table is not damaged and table indexes exist:

 

Then please navigate to the Errors & Subscriptions sub-tab and let us know if you see any error.

Also please leave your forum URL to allow us check it.

 

Reply
rtev
Posts: 10
 rtev
Topic starter
(@rtev)
Active Member
Joined: 4 years ago

Hi Robert, thank you for the swift reply.

Please find the subscriber table attached.

Issues & Rec tab: no issues found

URL: https://mijn.beleeff.nl

Reply
Robert
Posts: 9363
Admin
(@robert)
Support Team
Joined: 6 years ago

Thank you  rtev,

Where can we register to test the subscription process?

Reply
rtev
Posts: 10
 rtev
Topic starter
(@rtev)
Active Member
Joined: 4 years ago

I locked registrations, it's an invite only forum.

Can I send you an email invitation?

Reply
Page 1 / 3
Share: