Notifications
Clear all

wpForo 1.x.x [Solved] Change language with .po files doesn't work

9 Posts
4 Users
0 Likes
4,966 Views
Forronix
Posts: 9
Topic starter
(@forronix)
Active Member
Joined: 4 years ago

Hello guys,

I’m sure you all are annoyed of all these change language questions. But I didn’t find the solution and English is not my mothers tongue … so I need support finally.

Our wpforo version: 1.5.4
Active Theme: Classic

I tried to change the wpforo language to German. As I understood it should be done with a few simple steps:

  • Use the wpforo.pot file to translate/generate the wpforo-de_DE.mo and wpforo-de_DE.po files
  • Upload these two new files to wpforo/wpf-languages
  • Change the language of the wordpress site in “Settings”->”General”

 

But it doesn’t work.

What have I done?
First I used a translation which I found in your forum. Because it was from July, I added the missing rows at the end of the .po files with the rows of the original .po file from our server. (I used notepad++)
I didn’t wonder that this was not the solution…

So I did it like the manual:
I used Poedit and have opened the wpforo.pot file. I translated only a few phrases which I know that I will find these phrases at the front end.

After I created the .po and .mo file, I uploaded all three files (.pot, .po and .mo) to our fileserver. The names are all like the originals according to your manual. Then I change the wordpress language to English and back to German again and I deleted the cache of the forum (“delete all caches” – somewhere I have read that this will help).

But I don’t see any translation of the forum.

 

What is the problem?
Did I make something wrong?
I there a possibility to change the language at another place? (not only at “Settings”-“General” of the wordpress site)

 

I hope you can help me, I’m really desperate.

Greetings
Forronix

 

Topic Tags
8 Replies
Robert
Posts: 9278
Admin
(@robert)
Support Team
Joined: 6 years ago

Hi @forronix,

Please follow to the instruction below:

  • First of all if you see even one translated phrase it means the translation works, you just need make sure all phrases are translated. Are you see it's not translated?
  • Second please change your WordPress language to English, then change it back to German then delete all caches.
  • Also please deactivate wpForo and activate it again.
  • I'm sure this is a cache issue, sometimes WordPress doesn't recognize that a plugin has current language translation file.
Reply
1 Reply
Jacek.kaleta
(@jacek-kaleta)
Joined: 4 years ago

New Member
Posts: 2

In my case (Polish) it was a truth – not all phrases were translated. I found higher developed .mo/.po file and it is much more completed (though not all phrases are with "current" status). I’m really happy

Reply
Forronix
Posts: 9
Topic starter
(@forronix)
Active Member
Joined: 4 years ago

Hi @Robert

Long time no see. But the last days I got more time to try it again.
Unfortunately I didn’t find the solution yet. I have tried it as you described it.
There are no translations in our forum.

Normally I would try another way like the xml translation, but this will not solve the problem of the forum.

Is there a possibility to see which language .po file is loaded by wpforo?
Or can I force wpforo to use another language .po file by adding a code in the source code? (but this should be not the final solution)

I am frustrated. It looks so easy and it doesn’t work.

We also have got the following plug ins:

  • wpForo - User Custom Fields
  • wpForo Advanced Attachments
  • wpForo Embeds
  • wpForo Polls

Do we have to mind something regarding the plug ins?

Reply
Robert
Posts: 9278
Admin
(@robert)
Support Team
Joined: 6 years ago

Something is irregular on your website. wpForo doesn't have such issue. I recommend install the plugin called Loco Translate.

Reply
Forronix
Posts: 9
Topic starter
(@forronix)
Active Member
Joined: 4 years ago

You must be right.
I still can't translate it with Loco, but maybe it will help to solve the problem.

Loco seems to be a good plug in. I translated parts of another plugin and it works.
I recognized that there is a “sync”-fault with wpforo and its translation. I know this is not your plugin, but maybe you’ve got some experience:

After looking at the file info of the wpforo translation in Loco (“Plugins/wpForo/wpforo-de_DE.po” <- title in dashboard), there is following error Message:

Out of sync with template

PO file has different source strings to "wpforo.pot". Try running Sync before making any changes.

(Yes, I have tried the sync.)
Did you have seen something like this before?
I will also search for the fault and contact the developer of this plugin.
If I got the solution, then I will write you here again… maybe it can help someone else.

Reply
Page 1 / 2
Share: