Notifications
Clear all

wpForo 1.x.x [Closed] Embed a forum in a page has issue

5 Posts
3 Users
0 Reactions
527 Views
Posts: 15
Topic starter
(@fassett99)
Eminent Member
Joined: 4 years ago

Hi,

I embedded one forum in a page using the shortcode:  https://thewildtemple.com/00evelyn/

When I click on the forum name to be able to add or reply to posts - it keeps taking me to the home page.  I think it is because it tries to take me to the default page /community and that is protected.  I thought I would be able to interact with the forum on the page where it is embedded.  Any ideas? 

I unprotected the main forum page and it looks the user with the usergroup to see one forum sees it correctly and the forums I don't have access to are closed up - but I see the category headings for the forums I can't see.  

Is there a way to hide the categories also for the forums I can't see?

 

Thanks,

Evelyn

 

4 Replies
spider
Posts: 58
(@spider)
Trusted Member
Joined: 6 years ago

I don't know about shortcode but yes, you can hide the categories as much easy as forums.

 

2 Replies
(@fassett99)
Joined: 4 years ago

Eminent Member
Posts: 15

@spider  Thanks, I'll check.  It would be nice when I embed the forum topic within a page if I could stay on that page to interact with the forum.  

 

Evelyn

(@fassett99)
Joined: 4 years ago

Eminent Member
Posts: 15

Hi,

I made every other role to have no access to the category, but it seems they still show up. 

What setting should I adjust?

Evelyn

 

Robert
Posts: 10522
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @fassett99,

Please delete wpForo cache in Dashboard > Forums > Dashboard admin page.

Then delete your website cache.

Then leave some URL to check if a topic is private or not.