Notifications
Clear all

wpForo 1.x.x [Solved] Error 403 after moving

5 Posts
2 Users
0 Likes
576 Views
Kevin M.
Posts: 10
Topic starter
(@kevin-m)
Active Member
Joined: 2 years ago

Hi there 🙂 

Ok, here is my (new... gosh...) problem 😂 

I had to make some changes with my website and had to move the forum.

So I created an other website, with an other URL. And then I copied the MySQL data from the old one to the new one. And I copy/past every files of the old forum and put them at the new place.

For now, the new forum is absolutely perfect, everything's ok. But... I can't access anymore to the attached files.

Even if I copied them too (wp-content/wpforo/attachments and others folder), even if every attached files is on line and even if the forum correctly linked them, I can't see them.

I thought firstly that could be a chmod problem. But it seems not cause I tried everything (705, 745, 655... everything). Then I thought it could comes from a .htaccess file. But again, nothing there.

If someone has any idea 😊 

And sorry for my english. French guy's there 😄 

Topic Tags
4 Replies
Kevin M.
Posts: 10
Topic starter
(@kevin-m)
Active Member
Joined: 2 years ago

I forgot to say that :

- I still am on the same server

- Even if I try to write new message with an attached file, this new attached file can't be seen either

Reply
Kevin M.
Posts: 10
Topic starter
(@kevin-m)
Active Member
Joined: 2 years ago

I even changed the fileURL in the wp_wpforo_attachments table in the database but nothing has change :/ 

Ok I found that the problem was coming from "wpForo Advanced Attachments" plugin. If I delete it and try to attach files with the usual method, it works perfectly. I try to delete it and to reinstall it but still doesn't work :/ any idea ?

Reply
Kevin M.
Posts: 10
Topic starter
(@kevin-m)
Active Member
Joined: 2 years ago

Ok I think I found where it was coming from. It was the .htaccess of the wp-content/uploads/wpforo/attachments which were wrong. I renamed it to disable it, and now everything's fine 🙂 

Reply
1 Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1811
Posted by: @kevin-m

Ok I think I found where it was coming from. It was the .htaccess of the wp-content/uploads/wpforo/attachments which were wrong. I renamed it to disable it, and now everything's fine 🙂 

Who put .htaccess in there? Not wpForo.

Reply