Notifications
Clear all

wpForo 1.x.x Posting & replying slow

11 Posts
4 Users
4 Likes
799 Views
Timmeehh
Posts: 5
Topic starter
(@timmeehh)
Active Member
Joined: 1 year ago

Hey guys, hope somebody can help me. I have wpForo running which is great, but posting a new reply takes like 10-15 seconds. I would like to resolve that.

 

Steps I already tried:

 

- Checked the DB for InnoDB /MyISAM structures and fixed them if necessary. 

- Checked the cache settings in wpForo

- Checked the site health page of Wordpress (nothing weird there), just outdated PHP (/zip module being disabled) but that shouldn't matter.

- checked the wpForo debug -> error tab, but nothing there at all.

- Created a new forum & created a post to check if it would be the e-mail sending that would slow things, but on the new empty forum it would still take 10-15 seconds, so that's not the problem.

 

Is there something else I can try? Thanks a lot in advance. 

 

Topic Tags
10 Replies
dimalifragis
Posts: 1812
(@dimalifragis)
Noble Member
Joined: 3 years ago

It is probably your EMAIL server, sending out smtp emails.

Also if anybody else is reading that in the future, please STOP playing around with SQL engine types, i dunno who started this game.

Reply
Chris
Posts: 2317
Admin
(@chris)
Support Team
Joined: 1 year ago

Hi @timmeehh,

I guess you need to update MySQL(MariaDB) and PHP versions to the latest.

Reply
Timmeehh
Posts: 5
Topic starter
(@timmeehh)
Active Member
Joined: 1 year ago

@dimalifragis It's stated here by an admin: https://wpforo.com/community/faq/forum-is-slow/

 

@Chris I updated both and the issue is still here. It seems like it is indeed the email sending that makes things slow. Is there something I can do to make that better? I use wp-mail-smtp, should I use something else?

Reply
7 Replies
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1812
Posted by: @timmeehh

@dimalifragis It's stated here by an admin: https://wpforo.com/community/faq/forum-is-slow/

 

As i said, this is probably due to EMAIL (smtp/out) mail to your mail server.

https://wpforo.com/community/how-to-and-troubleshooting-2/5-sec-to-reply-is-it-normal/

Reply
Timmeehh
(@timmeehh)
Joined: 1 year ago

Active Member
Posts: 5

@dimalifragis You are absolutely right. I disabled wp-mail-smtp and replying got quick again. The problem is that if I don't use wp-mail-smtp, sending mails won't work at all. What should I do to get best of both worlds? I obviously need mail sending..

 

Note that I have hundreds of users. Might that be the problem?

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1812

@timmeehh 

Well this is tricky to answer. You MIGHT have an issue with sending smtp out, what are the logs of smtp plugin tell you?

If there are NO errors, then the delay is normal because of the ammount of emails as you say. In that case you want to QUEUE your emails, using some 3rd party email service or this:

https://wordpress.org/plugins/gd-mail-queue/

 

Reply
Timmeehh
(@timmeehh)
Joined: 1 year ago

Active Member
Posts: 5

@dimalifragis Thanks for the reply, this did the trick. Thanks for all the help!

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@timmeehh ,

In case you don't want to use SMTP solutions, you should use the default mail sending functions. wpForo can detect if the PHP mail() function doesn't work, this is the default WordPress function based on PHP mail() function. You can check it in Forums  > Tools > Debug > Error & Issues Tab, it'll show red marked information. You see that error, you should contact hosting support and ask them to enable it.

The link in the information section goes to: https://www.wpbeginner.com/wp-tutorials/how-to-fix-wordpress-not-sending-email-issue/

Reply
Timmeehh
(@timmeehh)
Joined: 1 year ago

Active Member
Posts: 5

@Robert Hey Robert, thanks for the reply. I am hosting everything myself, so I was 100% sure that was not the error. wpForo also shows 0 errors, so that's not the problem.

I figured it out (with the help of @dimalifragis), and the problem was that with every reply our site was sending out around 400 emails, which made posting slow. It worked, but again, our server sending out 400 mails takes a few seconds.

I understand that wpForo is not usually used with such a big user base, but this might become a problem for more people in the future. Changing the way emails are sent (for example using a queue as mentioned before) might be way better in a future release.

Our forum has never been faster. Posting now takes 0,4 seconds instead of 20-30.

Reply
Chris
Admin
(@chris)
Joined: 1 year ago

Support Team
Posts: 2317

Thank you, @timmeehh for your Suggestion, the Mail Queue is in our to-do list.

Reply