Notifications
Clear all

[Solved] Error messages help

11 Posts
2 Users
0 Likes
120 Views
NeilDep
Posts: 8
Topic starter
(@neildep)
Active Member
Joined: 2 months ago

I'm new to wpForo and whilst I'm happy with how its going I've just discovered these two errors in the log file. Can anyone explain them and say what I need to do?

There are dozens of copies of the first one, they seem to be generating every couple of minutes and have been doing so for the two days.

[01-Oct-2022 09:48:44 UTC] PHP Warning: Use of undefined constant ‘256M’ - assumed '‘256M’' (this will throw an Error in a future version of PHP) in /home/domainnameor/public_html/wp-config.php on line 23

The second one only appeared today and so far, there are about 20 copies.

[01-Oct-2022 09:45:26 UTC] Aq_Resize.process() error: Unable to resize image because image_resize_dimensions() failed

wpForo Version
2.0.9
WordPress Version
6.0.2
10 Replies
dimalifragis
Posts: 1830
(@dimalifragis)
Noble Member
Joined: 3 years ago

Hi,

Both issues are not related with wpForo.

1. What PHP version is that?

2. Is your memory settings in wp-config.php like this:

define('WP_MEMORY_LIMIT', '256M');

The last "image resize" issue comes from some plugin you may have. Aqua Resizer?

2 Replies
NeilDep
(@neildep)
Joined: 2 months ago

Active Member
Posts: 8

@dimalifragis Thanks for the reply.

PHP - 7.4.30 (Supports 64bit values)

define('WP_MEMORY_LIMIT', '256M');

I have no idea what this is or where to look to check.

I found the following  - The setting for post_max_size is smaller than upload_max_filesize, this could cause some problems when trying to upload files.

I'll investigate this but I'm guessing this is the cause of the error.

dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1830
Posted by: @neildep

@dimalifragis Thanks for the reply.

PHP - 7.4.30 (Supports 64bit values)

define('WP_MEMORY_LIMIT', '256M');

I have no idea what this is or where to look to check.

I found the following  - The setting for post_max_size is smaller than upload_max_filesize, this could cause some problems when trying to upload files.

I'll investigate this but I'm guessing this is the cause of the error.

Ok, then the cause of the error comes from some PLUGIN. The rest you write are not relevent to the error. It must be some plugin.

And all those are not releted to wpForo, they don't "come" from wpForo.

 

dimalifragis
Posts: 1830
(@dimalifragis)
Noble Member
Joined: 3 years ago

And this:

 

<!-- Dynamic page generated in 2.236 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2022-09-30 14:43:01 -->


 

is a no-go with wpForo. Exclude the page of wpForo (that has the shortcode) from Caching. Any caching. Didn't you got a WARNING in your Dashboard about it?

4 Replies
NeilDep
(@neildep)
Joined: 2 months ago

Active Member
Posts: 8

@dimalifragis More thanks.

Again, no real idea what this means and I did not see any warning as far as i can remember

dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1830

@neildep It means that you have Wordpress Super Cache plugin caching wpForo. And that doesn't work and you probably saw a warning at your Dashboard.

As i posted, EXCLUDE wpForo page from caching.

https://wpforo.com/community/faq/wpforo-and-cache-plugins/

The "community" url is in your case "forum".

NeilDep
(@neildep)
Joined: 2 months ago

Active Member
Posts: 8

@dimalifragis I did see that and I did add it to Rejected URL strings. Should I have just copy/paste the following or do I need to edit it in any way?

/community/
/participant/
/sign-up/
/sign-in/
/change-password/
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1830

@neildep It is /forum/ in your case not /community/.

dimalifragis
Posts: 1830
(@dimalifragis)
Noble Member
Joined: 3 years ago

I see you fixed it (the caching).

So does any issue seems resolved after that?

1 Reply
NeilDep
(@neildep)
Joined: 2 months ago

Active Member
Posts: 8

@dimalifragis  To be honest I wasn't aware of any issues to begin with, I simply saw the error log and posted on here. I had changed community to forum, so good to know I got that right.