Notifications
Clear all

[Closed] Error when specifying avatar in URL

10 Posts
2 Users
0 Likes
595 Views
Posts: 56
9 Replies
Robert
Posts: 10478
Admin
(@robert)
Support Team
Joined: 8 years ago

@user1038,

This URL cannot be set as Profile Avatar. Avatars are images and they must have either .jpg, .png, .gif or .webp extensions. Other URLs are not supported. here is an example of my avatar URL:

 https://wpforo.com/wp-content/uploads/wpforo/avatars/robert_1 .png
Posts: 56
Topic starter
(@user1038)
Trusted Member
Joined: 9 months ago

I would like to set up an avatar in the manner shown in the attached image, but I don't know how to add an extension to the URL.
What is the best way to add an extension to a URL?
I have looked online and have not been able to find a good way to do this.

Please let me know how to do this so that it is possible for users of the site.

1 Reply
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10478

@user1038,

You cannot modify URL and add extension. Just put the images into your WordPress media library, copy the URL and paste in the Avatar URL option. Or just use the upload custom avatar button.

Posts: 56
Topic starter
(@user1038)
Trusted Member
Joined: 9 months ago

Thank you very much.

So users other than the site creator cannot set avatars using "URL"?

1 Reply
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10478

@user1038,

Users have three options to put avatars. Gravatar.com, Avatar URL and Upload avatar image. 

Posts: 56
Topic starter
(@user1038)
Trusted Member
Joined: 9 months ago

So, if I use Gravatar, what are the steps for site users to upload their avatars?

Also, I have left the setting item enabled that says enable custom avatars.

1 Reply
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10478

@user1038,

Gravatar will be automatically displayed in forum. They should register at gravatar.com and upload their avatars.

Page 1 / 2