Notifications
Clear all

wpForo 1.x.x [Closed] Error with photos profile...

15 Posts
3 Users
0 Likes
908 Views
Posts: 38
Topic starter
(@never)
Trusted Member
Joined: 5 years ago

Hello,

In signature of articles on my blog, the photos of profile don't appear. I don't understand : authors have picture profile, but the blog take the default avatar.... 

Links of pictures to understand : 

 

Can you help me ? 

Thank you... 

 

14 Replies
Tutrix
Posts: 1186
(@tutrix)
Noble Member
Joined: 4 years ago

@never

add !important to height: 80px

/wp-content/themes/ekko/style.css (Line 5398)

.author-box-wrapper .author-avatar img, #comments .comment img {
float: left;
margin-right: 30px;
width: 80px;
height: 80px !important;
border-radius: 50%;
}
12 Replies
(@never)
Joined: 5 years ago

Trusted Member
Posts: 38

@tutrix

Than you for reply !

But this is not what i want... 

Look picture : 

At the end of article, the picture of author is not the good picture ! This is the default avatar of my site, but not the profile picture of the author. 

I want the real profile picture... 

Do you understand ? 

 

Thank you 

(@never)
Joined: 5 years ago

Trusted Member
Posts: 38

@tutrix
Same thing with the widget "authors", profiles pictures don't appears... 

Thank you 

Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1186

@never

try

Dashboard > Forums > Settings > Features Tab

activate

Replace Author Avatar with Forum Profile Avatar

or deactivate if already activated

(@never)
Joined: 5 years ago

Trusted Member
Posts: 38

@tutrix

Nothing change :/ 

Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1186

@never

By default, Wordpress only shows avatars uploaded to Gravatar

try a plugin like WP User Avatar to display avatars without Gravatar on your WP-Theme

(@never)
Joined: 5 years ago

Trusted Member
Posts: 38

@tutrix

I have already WP user avatar unfortunaly... 

And i tried to select "Disable Gravatar and use only local avatars", but this is the same thing : this is the default avatar that appear :/ 

Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1186

@never

upload Avatars over the "Wordpress-Profile", not over wpForo Profile to display in your "Wordpress Theme"

(@never)
Joined: 5 years ago

Trusted Member
Posts: 38

@tutrix

Don't work, i tried : if i change the profil picture or wordpress profile, this don't appear on the forum or in the blog : this is the WP user avatar that have the priority on all...

 

:/

Tutrix
(@tutrix)
Joined: 4 years ago

Noble Member
Posts: 1186

@never

I manage 4 blogs for friends
we also use the WP user avatar, my avatar (Wordpress-Profile) and the avatars (Wordpress-Profile) of my firends is shown on the blog and forum

For users without an avatar, the default "WP user avatar" is displayed on the blog and forum

Forum-Members use the avatar upload from wpforo. This avatar is only for display in the forum not for blog authors

(@never)
Joined: 5 years ago

Trusted Member
Posts: 38

@tutrix

Ok, so impossible to set the avatar of forum in avatar of Wordpress profil ? 

We should can because if i select "blank avatar" in avatar default, the blog show the avatars of forum... 

So it' just that the default avatar choosen have priority on the forum avatar ? can't we change the priority ? 

RealAct
(@realact)
Joined: 6 years ago

Reputable Member
Posts: 217

@never my forum is in Spanish so I forgot how things read in English, but I think what you need to do is go to WordPress/WPforo/Settings/Features/ then Enable "Change the User Avatar to the Forum Profile Avatar"

Then make sure you clean up all caches and check again.

 

(@never)
Joined: 5 years ago

Trusted Member
Posts: 38

@realact

Thank you, but already tried and nothing change :/ 

Posts: 38
Topic starter
(@never)
Trusted Member
Joined: 5 years ago

I found something : 

 

If i select a "blanck avatar default", the good picture profiles appears in the author signature articles. 

But i don't want just this, because in my forum 50% peoples have blanck image profile. 

 

But we know now that this is a problem of priority no ? 

 

Now : default avatar of "WP user avatar" have priority on avatar selected by user. 

 

-> Do you know how can i change this priority please... ?