Notifications
Clear all

wpForo 1.x.x [Solved] Failed to load plugin tinymce-pre.js

18 Posts
3 Users
2 Reactions
2,327 Views
Posts: 8
Topic starter
(@padailey)
Active Member
Joined: 4 years ago

I get this error when editing a topic

Failed to load plugin url: http://website.com/wp-content/plugins/wpforo/wpf-assets/js/tinymce-pre.js

I have tried to put this in the header file but it didnt work

<script type="text/javascript" src="http://mywebsite.com/wp-content/plugins/wpforo/wpf-assets/js/tinymce-pre.js"></script>

Β Wordpress Version 5.4

Could you help with this?

Thanks

Topic Tags
17 Replies
Sofy
Posts: 4573
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi @padailey,

Please leave some example URL to allow us to test it.Β 

Posts: 8
Topic starter
(@padailey)
Active Member
Joined: 4 years ago

The forum is here https://topfaucets.us/community/

You may need to post something and then try and edit it.

Your log in details

User: wpforo

Password: wpforo

Β 

Thanks for your help.

Β 

Robert
Posts: 10545
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @padailey,

You have two problems on your website.

First, is that you've not excluded wpForo home page from your WP-Super-Cache plugin. wpForo has its own cache system for the forum part, you should exclude the forum from your cache file. Please read the FAQ topic: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

Β 

Second, you should fix this JS syntax error. The Function should be changed to function.Β  Or this JS should be totally removed. I don't know what JS is this, it refreshes some iframe or it's an advertising JS. In any case, if you don't use it, you should remove it from your website header:

Β 

1 Reply
(@padailey)
Joined: 4 years ago

Active Member
Posts: 8

@robert

I removed the script from the header and deactivated WP-Super-Cache but I am still getting this error.

I gave these log in details admin role if needed.

User: wpforo

Password: wpforo

Robert
Posts: 10545
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @padailey,

This is http:// issue. You site was set with http:// protocol, but you use it with https://

We just set it to https:// but for some reason it stated to redirect unlimitedly. You should find and remove the old SSL redirection maker.

Your website does https to https redirection now, please use cPanel File Manager or some FTP client and change SSL redirection plugins you use. You can do that by renaming those plugins names.

If you can't fix this issue, just send FTP login details or cPanle login details to support[at]gvectors.com

12 Replies
Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

@padailey,

Your site is down now, please remove the https redirection plugin via FTP, or if you made redirection in .htaccess file, remove it from that. Or send FTP access to support[at]gvectors.com email address.

(@padailey)
Joined: 4 years ago

Active Member
Posts: 8

@robert

That worked, no error message. I will leave a review at the plugin page, and will also be looking into your other paid add-ons as there are a couple of them I am wanting.

Β 

Thanks

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

Thank you @padailey,

(@padailey)
Joined: 4 years ago

Active Member
Posts: 8

@robert

Sorry, It looked everything was working but getting this error, The page isn’t redirecting properly. I cleared the cookies and purged everything on Cloudflare and right now it is paused.

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

@padailey,

I already recommended what should you do. Please follow my post:

This is http:// issue. You site was set with http:// protocol, but you use it with https://

We just set it to https:// but for some reason it stated to redirect unlimitedly. You should find and remove the old SSL redirection maker.

Your website does https to https redirection now, please use cPanel File Manager or some FTP client and change SSL redirection plugins you use. You can do that by renaming those plugins names.

If you can't fix this issue, just send FTP login details or cPanle login details to support[at]gvectors.com

please remove the https redirection plugin via FTP, or if you made redirection in .htaccess file, remove it from that. Or send FTP access to support[at]gvectors.com email address

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

But I see it works fine now: https://topfaucets.us/community/

What plugin have you used to redirect your website to https:// protocol?

Is that a  or a code in .htaccess file?

 

 

(@padailey)
Joined: 4 years ago

Active Member
Posts: 8

@robert

A plugin named wordpress-https and I renamed it to off-wordpress-https, my home page, https://topfaucets.us/wp-login.php or https://topfaucets.us/wp-admin/ will not load but https://topfaucets.us/community/ and all others will load, that plugin is to fix parts of the page that isnt using https, I changed no code .htaccess file.

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

@padailey,

That plugin already done lots of changes in lots of places. You should never use such plugins without changing your URLs to https:// in Dashboard > Settings > General Tab.

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

@padailey,

Please read this article, it may help you:

https://www.wpbeginner.com/wp-tutorials/how-to-fix-error-too-many-redirects-issue-in-wordpress/

https://community.cloudflare.com/t/page-isnt-redirecting-properly-errors-on-wp-admin/1515/3

(@padailey)
Joined: 4 years ago

Active Member
Posts: 8

@robert

The problem is I can't get to the admin panel to do anything. It was working before you did what you did I just that warning we started out with.

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10545

@padailey,

Sure i see, so just let us fix it via FTP, if you can send FTP connection login to support@gvectors.com email address.

Or just change back these two URLs to http:// in wp_options table using cPanel > phpMyAdmin:

(@padailey)
Joined: 4 years ago

Active Member
Posts: 8

@robert

I do have offsite backups, but first I will try the database.

Β 

I got it back, all I need to do is not use that https plugin and manually fix most likely images that are using http instead of https. The errors for the forum are gone it seems to be because of that https plugin.