Notifications
Clear all

wpForo 1.x.x [Solved] File attachment

14 Posts
4 Users
0 Likes
2,531 Views
Posts: 1
Topic starter
(@amandagar5044)
New Member
Joined: 4 years ago

My subscriber are not able to see any file attachment button while adding topic in forum even having standard access. please help me getting the solution. ( www.brainics.in)

I have check the button in standard access (can attach file).

As a subscriber I can attach the document on this forum, why my subscriber are facing the issue.

please help me !!!!

13 Replies
13 Replies
(@crisw)
Joined: 4 years ago

Reputable Member
Posts: 281
Posted by: amandagar5044

My subscriber are not able to see any file attachment button while adding topic in forum even having standard access. please help me getting the solution. ( www.brainics.in)

I have check the button in standard access (can attach file).

As a subscriber I can attach the document on this forum, why my subscriber are facing the issue.

please help me !!!!

Hi @amandagar5044 ..

Try this:

1. Go to Forum Dashboard
2. Forum Accesses
3. Standard Access (This access is usually used for Registered usergroup)
4. Click "edit"
5. Check the "Can attach file" box
6. Click the UPDATE button at the bottom

7. Also check your settings at:

8. Forum Dashboard
9. Tools
10. then select the "Antispam" tab
11. Go to the "New Registered User" area ...
12. there is a setting there that says:
"Do not allow to attach files with the following extensions:"

My forum settings on "Do not allow to attach files with the following extensions:" are:

pdf|doc|docx|txt|htm|html|rtf|xml|xls|xlsx|zip|rar|tar|gz|bzip|7z

I visited your site and I see you might allow pdf documents for example, just make sure that you specify the extensions that you will allow on your site. (Notice the "do not allow" extensions above? If you allow pdf, then remove the pdf from the above list, then compare with your own settings).

I also noticed you have TWO installations of the wpForo in your website (One is "forum" and the other is "community", so you might want to thoroughly check BOTH settings on the TWO installations for the above steps,so your members can attach files to their posts.

I hope that helps. Let us know here if it did so others can also benefit from the above steps (if it works, that is).Β  Good luck and God bless you.Β Β  πŸ™‚Β Β 

Rajraj
(@rajraj)
Joined: 4 years ago

Active Member
Posts: 10

Hi Crisw,

Thank you for the information.. I Done everything what u said in this post... Then also its not showing the Attach File Option. Now what i want to do.

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

@rajraj,

Please leave your forum URL to allow us to check it. 

Rajraj
(@rajraj)
Joined: 4 years ago

Active Member
Posts: 10

Hi Sofy ,

Thank you for replying, This is my url pls check it and also image button browsing option also not view in tinymce editor pls help me to solved.

https://www.traystory.com/forum-communication/

 

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

@rajraj,

Please register some testing user and send the login details to info[at]gvectors.com email address. 

Please make sure the "Can attach file" permission/CAN is enabled. 

More info here: https://wpforo.com/docs/root/topics-posts/atatch-file-to-post/#access

Rajraj
(@rajraj)
Joined: 4 years ago

Active Member
Posts: 10

 

ya Sofy I send the testing login detail to your info mail pls check it

 

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

Thank you @rajraj,

We'll check and back to you asap. 

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

Hi @sofy,

Please navigate to Dashboard > Forums > Tools > Antispam admin page, make sure the value of the "Min number of posts to be able attach files" option is 0. And leave the screenshot of the section here.

 

Rajraj
(@rajraj)
Joined: 4 years ago

Active Member
Posts: 10

Thank You Sofy now it's working... and One more question in tinymce editor image button option is showing but i can't able to select the image. check my attachement. please help me to solve that issues

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

This is not wpForo codes. I'm really sorry, but I'm not familiar with it. 

However, I've checked and don't see any problem. As far as I know, it's not possible to select the image, you just need to insert the image URL, e.g: "https://wpforo.com/wp-content/uploads/2019/02/wpForo-Threaded-Forum-Layout-described.png" 

As you've already enabled the wpForo File attachment button I recommend you to delete all customization and just use the wpForo features. 

Rajraj
(@rajraj)
Joined: 4 years ago

Active Member
Posts: 10

K Thank you sofy. pls enable this function in your plugin. Your plugin is awesome but we miss this option. pls update this feature in future thanks you. and thank you for guiding me. your support is good

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4054

@rajraj,

What feature you mean? If you mean image embedding feature you can use the code explained in this support:

 
For an advanced attachment features please checkout wpForo Advanced Attachment addon:
Rajraj
(@rajraj)
Joined: 4 years ago

Active Member
Posts: 10

Thank you