Notifications
Clear all

Forum Deleted, Data Not Showing Up In Database Backups

3 Posts
2 Users
0 Reactions
137 Views
Posts: 7
Topic starter
(@codings)
Active Member
Joined: 11 months ago

Hi, this is a 2 part issue I came across today:

The first part...

In wpForo > Forums where the hierarchy is listed, I had a forum category A (blue panel) with a forum (grey panel) below it that had 5 posts. I dragged the forum panel and moved it to a category B. Then I deleted the category A because there were no longer any forums below it.

When I went to check the front end, the forum I moved was not there. I went back to check the admin page and sure enough the category and forum are not there.

I don't know why this happened but I think it could have something to do with the fact I sometimes have to do admin stuff twice. Such as making a change in the settings, I have to do it twice for it to take effect. No caching plugin is active, and forum caching is disabled but the server is lightspeed if that makes a difference.

The second part...

After realizing that regardless of how it happened, I probably won't be able to get the 5 forum posts back. So, I went to the backup dashboard on my hosting account and saved a backup from yesterday, hoping to be able to restore those 5 posts (since none of them were recently changed).

I created a new database to import the backup to and no wpForo tables are in the backup. I downloaded other backups from other dates, and again no wpForo content is there. Searching looks like others have had this issue as well. Other plugin data is intact, even plugins I've deleted, but no wpForo data.

With the info given, can someone please help me find a way to restore those posts and figure out why this plugin data is not being saved in standard db backups? Thank you.

2 Replies
Robert
Posts: 10545
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @codings,

After moving forum panels to category B you should scroll down and click the [Save forums order and hierarchy] button to save all your changes. If you didn't do this then you've not saved your changes.

You should contact your hosting service and ask them for database backup restoration. I'm sorry there is no other way to restore the deleted posts.

Reply
1 Reply
(@codings)
Joined: 11 months ago

Active Member
Posts: 7

@robert Thanks, I found that. You guys might consider moving that button to the right side where it is more intuitive since all of the other save buttons are on the right as well.

It's a little tricky that the drag and drop seems like it's working ajax style, then after dragging and dropping, you go to delete the empty blue panel and it takes you to another page to confirm delete, only to find that everything is gone.

The first important tip on the Categories and Forums page is: "Please drag and drop forum panels to set parent-child hierarchy." How about adding some language to indicate that you'd better save it after each drag and drop to make sure you don't delete an empty blue panel and lose the entire forum that used to be under it.

No need to contact the host for the backup, I can access all backups from each day, but the point is that no backups have the wpforo tables in them.

Posted by: @codings

I created a new database to import the backup to and no wpForo tables are in the backup. I downloaded other backups from other dates, and again no wpForo content is there. Searching looks like others have had this issue as well. Other plugin data is intact, even plugins I've deleted, but no wpForo data.

 

Reply