Notifications
Clear all

[Solved] Forum not showing to members?

7 Posts
2 Users
0 Likes
232 Views
Posts: 5
Topic starter
(@dxvid55)
Active Member
Joined: 3 months ago

Hi, this is my first post here.

I've recently installed wpForo and everything seemed to be working well, but I have just discovered that the forum doesn't appear when I log in as a member?  (It does appear when logged in as "admin" and to guests who are not logged in.)  I searched google but couldn't find this particular issue or a fix.  Have attached a screenshot of how the forum appears to guests.  ( The "Recent Forum Posts" side-menu also shows "no posts found".)

https://www.mprem2.com/community/

Thanks for any help,

David.

wpForo Version
2.1.1
WordPress Version
6.1.1
6 Replies
Posts: 5
Topic starter
(@dxvid55)
Active Member
Joined: 3 months ago

Managed to fix this myself.
In Usergroups the Usergroup "Customer" and "Registered" were both set to User Role "Subsriber" so changed Customer (I don't use this) to "Contributer". Then press Synchronize. Then I ran all the maitenance tasks on the Overview page, purged all caches and Forum now appears for members.

Btw great plugin, I have enjoyed using it so far. 😀 

5 Replies
(@dxvid55)
Joined: 3 months ago

Active Member
Posts: 5

There was an error message in the User Roles table which said something like "you can't have the same User Role for 2 Usergroups" and Subscriber was populated with 0 Members and 0 Users.

Don't know where wpForo got these settings (ie Customer as Subsciber), thought it might have been Ultimate Member but couldn't find it there or elsewhere?

Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2777

@dxvid55,

WordPress User Role - wpForo Usergroups synchronization by default.

Administrator - Admin

Editor - Moderator

Author - --

Contributor - Customer

Subscriber - Registered

If you want to set new registered users as Subscriber/Registered, navigate to:

Dashboard > Settings > General: New User Default Role - Subscriber

Dashboard > wpForo > Usergroups: Set as Default button.

(@dxvid55)
Joined: 3 months ago

Active Member
Posts: 5

@chris The settings are fine as they are now.  I just don't know why it began with Customer set to Subscriber rather than Contributor?

Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2777

@dxvid55,

Not sure about that.

If you need any help, let us know.

(@dxvid55)
Joined: 3 months ago

Active Member
Posts: 5

@chris Thanks.

I might have changed the setting in a plugin I've deleted, whilst trying out different plugins after first installing Wordpress a few months ago.