Notifications
Clear all

wpForo 1.x.x [Closed] Forums link on main page leads to 404, is not updated

14 Posts
2 Users
0 Likes
1,052 Views
Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago

The forums link still remains unchanged on the main page ( https://192.168.1.42/wordpress/community) but it is redirected to the one I set ( https://192.168.1.42/wordpress/forums), which also works if I enter it manually. Strange but I can live with that.

2 Replies
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2539

@redglyph No, not correct. The page with the [ wpforo ] shortcode should be the same (name and slug) with the one you put in wpforo settings, Forum Base URL.

Please do not skip issues. You will encounter them after ...

(@redglyph)
Joined: 2 years ago

Active Member
Posts: 14

@dimalifragis I would normally agree, I'm discovering it so there's a few things to take in. I'm evaluating the possibility of using WP and wpForo to create a site with news and links to forums for discussing those news topics. So I'm just trying to see if it fits my requirements before looking at the details.

I didn't see anything suspect when enabling the debug mode and looking the debug info in the generated page (the same link with "community" appears in the forums luckily, so the debug info was available). And the link is correctly set in the database.

I don't have a precise idea of how the WP's main page is set yet, just the main idea. But trying to edit the "Forums | sample page" to see the details seems to imply changes so I won't do that. I see, however, that in the WP dashboard / Appearance / Menus, Edit Menus, this "Forums" URL is apparently set with "/%wpforo-home%/" (also mentioned here). That's as far as I can get now, I have no idea why it doesn't have the correct URL (hard-coded in PHP?) or why the "community" URL still leads to the correct page.

dimalifragis
Posts: 2539
(@dimalifragis)
Famed Member
Joined: 4 years ago

What the menu (as you mention above) has to do with forums or community slug?

What is the slug of the PAGE with the shortcode ?

2 Replies
(@redglyph)
Joined: 2 years ago

Active Member
Posts: 14

@dimalifragis I have no idea. I thought it was a WP feature and that wpForo had injected new shortcuts for the user to place on the navigation bar at the top. I see now that if I disable the forums, this "Appearance / Menus" disappear, so does it mean it's a forum setting that is shown in the WP dashboard settings? That's why I was confused I guess.

To be sure there is no confusion: the main page of the WordPress blog shows, at the top right, a "Sample page" after installation.

After installing wpForo, a new "Forums" link appears at its left. The same "Forums" link is visible in the forums too, since it is a page with the regular header, and a "[wpforo]" slug that displays the forums.

Those links are wrong, they point to https://192.168.1.42/wordpress/community after I changed the forum base URL to "forums".

So this is coming from somewhere else, but I don't know where. I'm not proficient with WP or wpForo, so for now I'll give up on that issue.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2539

@redglyph Ok, take your time.

wpForo has its own Menu, auto-created. Separate from Wordpress. Anyways, it seems you need some time, so feel free to ask when ready.

Page 2 / 2