Notifications
Clear all

Style [Solved] Guests see "Add Topic" button - even if settings are right

21 Posts
4 Users
0 Likes
417 Views
DanielOfAnu
Posts: 19
Topic starter
(@danielofanu)
Active Member
Joined: 2 years ago

Hello,

 

I've disabled Can Add Topic in the Forum Access for Guests, see attached.

For each forum created, I then gave Read Only access to everyone.

 

The problem is, I do not want guests to be able to see or click the "Add Topic" button.

 

How do I fix this bug?

 

Thanks in advance

 

 

20 Replies
DanielOfAnu
Posts: 19
Topic starter
(@danielofanu)
Active Member
Joined: 2 years ago
Reply
DanielOfAnu
Posts: 19
Topic starter
(@danielofanu)
Active Member
Joined: 2 years ago

 One further issue, how can I disable the "Login" or "Register" bar on the bottom of this page for Guests?

Further, how do I disable the "Quote" button for Guests?

 

https://anuinitiative.org/updates/initiatives/test-topic/#post-1

 

 

Reply
Martin
Posts: 868
Moderator
(@martin)
Support Team
Joined: 6 years ago

@danielofanu,

This is not a bug. All works correct. The button only exists for attracting guests to login or register, it doesn't allow creating topics, so the topic creation permission is disabled.

If you don't want to attract not-loggedin users to login or register, you can hide the button using a simple CSS code. Put this code in Forums > Settings > Styles > Custom CSS Code textarea, save it, delete all caches:

#wpforo #wpforo-wrap.wpf-guest .wpf-head-bar-right .wpf-button,
#wpforo #wpforo-wrap .wpf-please-login{
     display:none;
}

 

Reply
8 Replies
DanielOfAnu
(@danielofanu)
Joined: 2 years ago

Active Member
Posts: 19

@martin Thanks for this - just managed to get rid of it

One more question, how do I disable the "Quote" button for Guests?

 

https://anuinitiative.org/updates/initiatives/test-topic/#post-1

Reply
Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 868

@danielofanu,

Add this CSS to others in the same textarea:

#wpforo #wpforo-wrap.wpf-guest .wpfl-2 .wpforo-post .wpf-right .wpf-post-button-actions{
    display:none;
}
Reply
DanielOfAnu
(@danielofanu)
Joined: 2 years ago

Active Member
Posts: 19

@martin this is how the code looks now, but the Quote button is still there

 

#wpforo #wpforo-wrap.wpf-guest .wpf-head-bar-right .wpf-button,
#wpforo #wpforo-wrap .wpf-please-login{
display:none;
}

#wpforo #wpforo-wrap.wpf-guest .wpfl-2 .wpforo-post .wpf-right .wpf-post-button-actions{
display:none;
}

Reply
Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 868

@danielofanu,

I assume you know that you should delete the cache after each editing of css code, I have already said  you in my first post to delete the cache, I didn't want to write the same twice. So please delete the cache.

Also, exclude the forum page from your unintuitive cache plugin. Read this topic and exclude the forum page from LiteSpeed Cache as son as possible: https://wpforo.com/community/faq/wpforo-and-cache-plugins/

Reply
DanielOfAnu
(@danielofanu)
Joined: 2 years ago

Active Member
Posts: 19

@martin I added the forum to the LiteSpeed Cache exceptions.

 

I also cleaned Cache on wpForo, and the Quote button still appears.

 

Any ideas?

Reply
Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 868

@danielofanu,

You did something wrong, the forum page is still cached by your cache plugin. 

Are you sure you've inserted this /updates/ to the Do Not Cache URLs option of LiteSpeed Cache plugin?

https://buildwoofunnels.com/docs/checkout-pages/caching/litespeed-cache/

Reply
DanielOfAnu
(@danielofanu)
Joined: 2 years ago

Active Member
Posts: 19

@martin Thanks again for the quick reply

 

I've done exactly that - see attached

Reply
Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 868

@danielofanu,

I'd recommend connecting this plugin support and ask them why the forum page with sub-pages are not excluded from cache.

If there is no help then change your cache plugin to something more manageable (WP Super Cache, WP Fastest Cache)

 

Reply
dimalifragis
Posts: 1813
(@dimalifragis)
Noble Member
Joined: 3 years ago

You have issues (errors) on your pages:

 

 

Uncaught TypeError: elem is null

https://anuinitiative.org/updates/:163 6" role="listitem">    change https://anuinitiative.org/updates/ :1636
https://anuinitiative.org/updates/:163 3" role="listitem">    setInterval handler* https://anuinitiative.org/updates/ :1633

2 https://anuinitiative.org/updates/:1636: 3" href="https://anuinitiative.org/updates/">updates:1636:3

 

AND REMOVE THIS FROM YOUR PAGE of wpForo:

 



<!-- Page generated by LiteSpeed Cache 4.6 on 2022-05-16 09:11:51 -->
Reply
3 Replies
DanielOfAnu
(@danielofanu)
Joined: 2 years ago

Active Member
Posts: 19

@dimalifragis I've added the link to the forum to LiteSpeed Cache exceptions

 

Any other things I should check for?

Reply
Martin
Moderator
(@martin)
Joined: 6 years ago

Support Team
Posts: 868

@danielofanu,

Reset and purge all kind of minification, and otpization caches. I see the custom CSS doesn't exists in the website frontend, so this is 100% cache. After purging all kind of caches and deleting them, pres Ctrl+F5 twice on forum front-end to delete browser cache. i think this could be browser cache as well. 

Or just wait for 1-2 days, and you'll see the result, all caches have aut-reseting times.

Reply
dimalifragis
(@dimalifragis)
Joined: 3 years ago

Noble Member
Posts: 1813
Posted by: @danielofanu

@dimalifragis I've added the link to the forum to LiteSpeed Cache exceptions

Well you didn't. Or did it the wrong way. CHECK your html page source bottom. You will see the signature.

Also the issues i posted above are not fixed.

 

Reply
Page 1 / 2