Notifications
Clear all

wpForo 1.x.x [Closed] Forums link on main page leads to 404, is not updated

14 Posts
2 Users
0 Reactions
1,355 Views
Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago

Hello,

I installed WordPress and wpForo and enabled it, then I configured the forums by adding a few categories.

On the main WP page is a link to the forums, when I click on it, I get a 404.

I don't have apparent issues with WordPress itself, though I haven't tried to add posts yet. Only browsed the configuration panels.

Details on the configuration:

  • It's installed on a local Linux VM with an Apache server. The URL of wordpress is "https://<IP>/wordpress" (see details down the post)
  • "Turn WordPress to wpForo" is OFF as per default (I don't want that)
  • On the dashboard, in Forums / Settings, the default link to the forum is "https://<IP>/wordpress/community", so it correctly detected the /wordpress alias, at least
    • I later tried to change it to "https://<IP>/wordpress/forum" => I see the link on the main page is not updated.
    • If I enter the URL by hand => it doesn't solve the problem, even after a hard refresh (Ctrl-F5).
    • I tried "Delete All Caches" from the dashboard / Forums / Forum Maintenance panel => no change.
  • All other settings are the default ones.

Here is an excerpt of the Apache configuration file, in case it's relevant. I need several applications and a default static option, hence the aliases.

<Directory />
    AllowOverride none
    Require all denied
</Directory>
 DocumentRoot "/usr/share/webapps/top"
<VirtualHost *:80>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*)  https://%{HTTP_HOST}%{REQUEST_URI} 
</VirtualHost>
<VirtualHost *:443>
    ...
    <Directory "/usr/share/webapps/wordpress">
        Options Indexes FollowSymLinks
        AllowOverride None
        Require all granted
    </Directory>
    Alias "/wordpress" "/usr/share/webapps/wordpress"
    ...
</VirtualHost>

What else I've tried:

  • both with admin login or as a visitor
  • from a local computer or from the VM with 'localhost'
  • change the permalinks to Numeric

 

Anyone has an idea of what I'm doing wrong?

13 Replies
Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago

While testing different things, including the permalinks options, I got the following warning when setting it to "Plain":

IMPORTANT: wpForo can't work with default permalink, please change permalink structure

The problem is that "Plain" is the only setting currently working with WordPress. The others lead to issues when trying to see the posts. And despite the warning, it seems the only one that works with wpForo too. So I'm not sure why this warning is given?

1 Reply
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2615

@redglyph What you try to do, doesn't work.

Default permalinks do NOT work wpForo.

If you have issues with changing that in Wordpress, this is not an issue of wpForo or Wordpress but of your installation.

Do not install plugins on a new Wordpress that is not working right. It will be impossible to track down from where an issue comes from. have a stable WP first and then continue.

Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago

If I try to register, when I'm not logged as my WP admin, I get a 404 too. My server is local on 192.168.1.42:

https://192.168.1.42/wordpress/community?foro=signup&redirect_to=https%3A%2F%2F192.168.1.42%2Fwordpress

Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago
Posted by: @dimalifragis

If you have issues with changing that in Wordpress, this is not an issue of wpForo or Wordpress but of your installation.

Do not install plugins on a new Wordpress that is not working right. It will be impossible to track down from where an issue comes from. have a stable WP first and then continue.

It may well be the case, though I don't see any issue with the default setting and WordPress.

My question was precisely to understand what I was doing wrong, so that's not helping much.

Posts: 14
Topic starter
(@redglyph)
Active Member
Joined: 2 years ago

I've changed the server so that it used php7 instead of the standard php (8), re-installed WordPress and wpForo from scratch, same outcome.

php7 version: 7.4.29-2

No issue whatsoever with other websites like phpAdmin, DokuWiki.

2 Replies
dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2615

@redglyph Ok, can you ENABLE debug to a LOG and after a while doing things, CHECK the log?

Also wpForo has a Tools / Debug option. Are all ok in there?

(@redglyph)
Joined: 2 years ago

Active Member
Posts: 14

@dimalifragis I think I found the culprit:

AllowOverride None

needed to be changed to:

AllowOverride All
Order allow,deny
Allow from all

or the .htaccess couldn't rewrite the URL.

I tried to enable the Apache logs to trace the rewrites but wasn't seeing anything in the error_log. That's why.

Now I can register on the forum and the errors I had in my first post seem to be solved. Maybe switching to php7 helped too, but I'm not sure.

Thanks for your help and your patience!

Page 1 / 2