Notifications
Clear all

Forums visible to Admin but not other users

6 Posts
2 Users
0 Likes
210 Views
Posts: 11
Topic starter
(@skinerd)
Active Member
Joined: 6 years ago

Hi, Since updating to version 2 I’ve been having some issues.

Currently, all the forum topics are visible to me as the admin but other users are unable to see them. When I login with a test user I can’t see them until I delete the forum cache. Then they appear briefly… but they are gone again the next time I login. 

wpForo Version
2.0.9
WordPress Version
6.0.2
5 Replies
Chris
Posts: 2777
Admin
(@chris)
Support Team
Joined: 2 years ago

Hi @skinerd,

Please exclude wpForo From your cache plugin.

Check wpForo and Cache Plugins FAQ Topic: https://wpforo.com/community/faq/wpforo-and-cache-plugins/#post-37150

And also make sure that your user's usergroup is set to standard Access in the Forums Categories/Forums > Forum Permission field.

Reply
Posts: 11
Topic starter
(@skinerd)
Active Member
Joined: 6 years ago

Thanks for the reply. I’ve tried both of those things. In fact, I’ve disabled the caching plugin for the moment. 

I’ve discovered it only happens for certain users but not others, even though they have the same user role. The user roles aren’t syncing properly for those who can’t see the forums. It just says ‘user synced’ like the attached image. 

Reply
Posts: 11
Topic starter
(@skinerd)
Active Member
Joined: 6 years ago

I can delete the cache or re-sync the users, and the forums become temporarily visible… but as soon as the user logs out and logs back in, they disappear again.

Reply
Posts: 11
Topic starter
(@skinerd)
Active Member
Joined: 6 years ago

Please help, my forums have been down for several days now, and my members are getting restless!

Reply
1 Reply
Chris
Admin
(@chris)
Joined: 2 years ago

Support Team
Posts: 2777

@skinerd,

Try only by deleting cache, if that makes the topics appear, you need to find out the plugin which caches the forum.

Reply