Notifications
Clear all

wpForo 1.x.x [Solved] How to add a custom message on WPforo login page

8 Posts
4 Users
1 Likes
1,167 Views
VivianE
Posts: 5
Topic starter
(@viviane)
Active Member
Joined: 2 years ago

How to can I add a custom welcome message on wpforo login page??

For example instead of “Forum Login” I could write “welcome to……” anything I wish to write.

7 Replies
Tutrix
Posts: 827
(@tutrix)
Noble Member
Joined: 3 years ago

@viviane

You can use the "Quick Translation – Phrases" for this
search for "Forum - Login" and insert your text as translation

Reply
4 Replies
VivianE
(@viviane)
Joined: 2 years ago

Active Member
Posts: 5

@tutrix Thank you for your response, it worked! I am trying to create a redirect for my login page because I want the login page content to be available on my Wordpress page.

creating the redirect always fail. I am creating the redirect correctly from my cpanel so I suspect there are parameters in my woforo login page Url  which is preventing redirect.

 

please, look at the url below and advise me how I might adjust the url code to enable the redirect;

https://forum.vivibosslink.com/?foro=signin&redirect_to=https%3A%2F%2Fforum.vivibosslink.com%2F

 

Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@viviane 

Please let me know how are you creating the redirection?

Please leave detailed steps and screenshots. Make sure you redirect to this URL:

 https://forum.vivibosslink.com/?foro=signin 

 

If you have already used a wrong URL then it's cached in your browser, and you'll not see the correct URL even after using the correct URL. You should use a new browser with a private session tab to check the redirection. Each change should be checked with new browser. This is the big issue of almost all browsers, once they do wrong redirection, they'll always remember that, and they'll to correct one.

Reply
VivianE
(@viviane)
Joined: 2 years ago

Active Member
Posts: 5

@robert thank you for your reply. I have removed my wpforo setting from turning wordpress to a stand alone forum. so, my the page no longer returns a 404 error, however, the redirect still doesn’t work! Please see the screenshot attached;

My hosting support said they could be something wrong with the login parameters; 

?foro=signin

causing the redirect to fail.

 

I am using the redirect cause I want the content on my word press forum login page;

https://forum.vivibosslink.com/?foro=signin

To be available on one of my wordpress pages;

https://forum.vivibosslink.com/login/

if there is any way else to achieve other than a redirect. For example a short code. I will appreciate the alternative solution as well.

 

Thank you for your responsiveness and support. I will really like if this is resolved as it is important to me.

If this is resolved, I will go ahead and give you plugin a 5/5 rating on wordpress.org forum and leave an excellent review as well.

 

please assist.

Reply
Jesus
(@jesus)
Joined: 2 years ago

Reputable Member
Posts: 287

@tutrix Hi mate. Something very strange happened to me in your forum the other day. For not apparent reason, out of nowhere, I found myself baneed from your forum. I have contacted you as its admin but as for time being I haven't received any reply from you. 

did you received my email explaining/asking you for this issue? Thanks 🙂

Reply
VivianE
Posts: 5
Topic starter
(@viviane)
Active Member
Joined: 2 years ago

I deleted my browser cache, redirected to the corrected url you sent to me yet the redirected still isn’t working.

 

my web host support said there could be a problem with the parameters; ?foro=signin in the url that prevents redirect.

Please help me look into this

Reply
1 Reply
Robert
Admin
(@robert)
Joined: 7 years ago

Support Team
Posts: 9912

@viviane ,

What page is this??

https://forum.vivibosslink.com/login/

It's currently 404. So it doesn't exist. Why are you redirecting wpForo login page to this 404 page?

I suppose you've enabled the "Turn WordPress to wpForo" option in Dashboard > Forums > Settings > General admin page. You should understand that this option will disable all plugins and WP pages on frontend. Please read attentively the description of this option before using it: https://wpforo.com/docs/root/getting-started/forum-page/turn-wordpress-to-wpforo/

If you want to make it available on front-end you should put that page URL in the "Exclude Page URLs" textarea in the same admin page.

So, if you enable "Turn WordPress to wpForo" option then you should only use wpForo on front-end. Nothing else will be available on front-end all will be 404.

Reply