Notifications
Clear all

wpForo 1.x.x [Solved] Keep getting a 404 on the entire forum

7 Posts
3 Users
1 Reactions
703 Views
Posts: 4
Topic starter
(@timon)
Active Member
Joined: 5 years ago

I have freshly installed wpforo on my wordpress instance, on my local machine it works. but if i then move it to my server it only gives a 404. I have gone throught the 5 steps stated here: https://wpforo.com/community/faq/forums-dont-show-up-on-the-main-page/ but nothing works. Tried the debug information but it is also not helpful, who could help me with this? 

Ps: I tried it without any other plugins and also with the default wordpress themes, there it also doesn't work.

Attached screenshot

6 Replies
Posts: 988
Moderator
(@martin)
Support Team
Joined: 8 years ago

Hi @timon,

Please navigate to Dashboard > Forums > Settings > General Tab and click on [Update Options] button.

Then navigate to Dashboard > Settings > Permalinks admin page, make sure it's not set the ?p=1 one and click on the [Update Options] button.

Then navigate to Dashboard > Forums > Dashboard admin page and click on the [Delete all caches] button.

 

If problem is not fixed, please leave some URL.

5 Replies
(@timon)
Joined: 5 years ago

Active Member
Posts: 4

Hi @martin,

Thanks for the quick reply, tried those steps again just to be sure, yesterday i also deleted my .htaccess file just to be sure (after changing the permalinks wp will generate it again). But nothing works, the forum is behind a login, how could we proceed with this?

 

Moderator
(@martin)
Joined: 8 years ago

Support Team
Posts: 988

@timon

There is no any info that could help you to understand your problem. Please open it or leave some test user login details.

Also, please navigate to Dashboard > Forums > Tools > Debug > Errors & Issues Tab and let us know what you see. Check the Table tab too.

(@timon)
Joined: 5 years ago

Active Member
Posts: 4

Hi @martin,

 

I mean could i leave some test user login details to you in a private message? It seems a bit insecure to leave it in a public forum. I checked the errors & issues, it has no error logs and it says no issues found. Tables are also fine. 
It is on a test server for now without a domain name, the url is http://46.17.7.215/~blackcaps/forum  Could this gives issues?

Robert
Admin
(@robert)
Joined: 8 years ago

Support Team
Posts: 10526

@timon

ok, i see the problem.

This problem comes from the "~" symbol in URL of your website.
This problem will be fixed in next version. You can fix it manually now.
 
Please option this file: /wp-content/plugins/wpforo/wpf-includes/functions.php
Find this function:
 
function wpforo_urlencode($str){
if( !preg_match('#^(\#post-\d+|https?:)$#isu', $str)
        && !preg_match('#([\?\&][^\?\&/=\r\n]*=?[^\?\&/=\r\n]*)(?1)*$#isu', $str)
        && $str === urldecode($str) )
$str = urlencode($str);
return $str;
}
 
Replace it with this:
 
function wpforo_urlencode($str){
if( !preg_match('#^(\#post-\d+|https?:)$#isu', $str)
        && !preg_match('#([\?\&][^\?\&/=\r\n]*=?[^\?\&/=\r\n]*)(?1)*$#isu', $str)
   && strpos($str, '~') === false
        && $str === urldecode($str) )
$str = urlencode($str);
return $str;
}
(@timon)
Joined: 5 years ago

Active Member
Posts: 4

@robert

You sir are a lifesaver, i had a suspicion it was the ~. 
It is of course a temporary server but i have to show the site tomorrow and now i can.
Thanks for all the help @martin and @robert