Notifications
Clear all

wpForo 1.x.x [Closed] Language of subscription notification email

5 Posts
3 Users
1 Reactions
1,634 Views
Posts: 6
Topic starter
(@iraina)
Active Member
Joined: 6 years ago

hi, 

I am using WpForo on a mostly Dutch-language website. We're using the new "Formal Dutch" translation for Wordpress (in Settings -> General -> Site Language) , and I created Formal Dutch wpforo-nl_NL_formal.po / wpforo-nl_NL_formal.mo translation files and put them in the wpforo/wpf-languages/ directory.

This works fine as far as the front-end is concerned, but the subscription emails that the system sends to people still partly has the English phrases (marked in red), and one in Dutch (marked blue): 

Hello (...)<br>
  New reply has been posted on your subscribed topic - <a href="{link-to-post}">{topic-title}</a>.
  <br><br>
  <strong><a target="_blank" href="{link-to-post}">{topic-title}</a></strong>
  <blockquote >
  {post text}
  </blockquote>
  <br><hr>
  If you want to unsubscribe from this topic please use the link below.<br>
 {unsub link}">Abonnement beëindigen</a>

Do you know how I could make it so that these emails would be completely in Dutch?

I noticed that in WpForo's Forums -> Front-end Phrases all the phrases are still in English, apart from a few that I translated by hand before I knew about the .po / .mo files. Also, there's a selector above the list (to the right of the "Bulk Actions" selector and the "Apply" button), but I cannot select Dutch in there - it only has English as a value. 

Not sure if that is related to the problem with the subscription notification email texts, but I can't seem to figure out how this works, and I can't find it in the documentation either. I would expect that I should be able to select other languages there, especially because there are a load of po/mo translations available in the wpforo/wpf-languages/ directory.

Thanks in advance for your help!  😊 

Iraina

4 Replies
Posts: 6
Topic starter
(@iraina)
Active Member
Joined: 6 years ago

Ah yes, and another question about the same topic: is it possible to set those email messages to "text" instead of "html" ?

Sofy
Posts: 4478
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi Iraina,

you need to translate wpForo emails texts manually from Dashboard > Forums > Settings > Emails admin page. 

Posts: 6
Topic starter
(@iraina)
Active Member
Joined: 6 years ago

gee ... I can't believe I missed that! Thanks!!

Robert
Posts: 10526
Admin
(@robert)
Support Team
Joined: 8 years ago
Posted by: Iraina

Ah yes, and another question about the same topic: is it possible to set those email messages to "text" instead of "html" ?

I'm sorry but wpForo only sends HTML emails.