Notifications
Clear all

wpForo 1.x.x logged in users getting a 502 Bad Gateway error

4 Posts
3 Users
0 Likes
727 Views
Ansen
Posts: 23
Topic starter
(@ansen)
Eminent Member
Joined: 4 years ago

Most of my logged in users are getting a 502 Bad Gateway error when attempting to view a post on the Forum. I read that this is a cookie problem and can be solved by clicking on "mark all read".  How can I "mark all read" for every user? 

3 Replies
Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 7 years ago

Well that error is common in Wordpress and it is a hosting problem. It usually meas that the  webserver can't figure out the invalid response from a requested page.

That could mean a lot of things, a slow server or db is a possible reason. Could also be a DNS problem. Could be something been offline (a db?).

I highlt doubt it has to do directly with wpForo.

 

Reply
Ansen
Posts: 23
Topic starter
(@ansen)
Eminent Member
Joined: 4 years ago

For the last 3 weeks I have been working with my hosting company trying to figure the cause of the 502 Bad Gateway error. The host company says it is not a hosting issue.

The 502 Bad Gateway error is only seen by old logged in users when Forum Cookies is Enabled. If users mark "all read" it sometimes fixes the problem for some users.  Any expertise would be appreciated. 

 

Reply
Martin
Posts: 868
Moderator
(@martin)
Support Team
Joined: 6 years ago

This is a browser-specific issue, so the rate of such a problem is too small. It can be solved if you set wpforo_max_logged_topics value to 50 via according filter hook. Please put this code in your active theme functions.php file:

function my_wpforo_max_logged_topics( $num ){
return 50;
}
add_filter('wpforo_max_logged_topics', 'my_wpforo_max_logged_topics', 12);

function my_wpforo_cookie_max_logged_topics( $num ){
return 50;
}
add_filter('wpforo_cookie_max_logged_topics', 'my_wpforo_cookie_max_logged_topics', 12);

 

How to Easily Add Custom Code in WordPress (without Breaking Your Site)

 

Or you can disable all forum cookies in Dashboard > Forums > Tools > Privacy & Rules admin page. But the first solution is better.

Forum Cookies
Reply