Notifications
Clear all

wpForo 1.x.x [Solved] 502 Bad Gateway error after publishing a topic

7 Posts
3 Users
3 Likes
1,165 Views
Chusman
Posts: 10
Topic starter
(@chusman)
Active Member
Joined: 4 years ago

Some days ago I recive this error after publishing any topic or answer. The topic is published but, after that I can't access to read any post in the forum.

I can do it with other advices but not with the browser in my computer

 

Edit:  https://www.deviolines.com/forum/

Topic Tags
6 Replies
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @chusman,

We've just checked and don't find such an issue. Could you please tell me a little more about the issue? And when exactly (in which browser) are you running into this error? Also please let us know the wpForo/WordPress versions. 

Chusman
Posts: 10
Topic starter
(@chusman)
Active Member
Joined: 4 years ago

I'm working with Chrome for Mac Versión 72.0.3626.119 (Build oficial) (64 bits) in a iMac with El Capitan OSX. 

Right now, If I'm logged out, I can't load any topic, I always receive the 502 error. When I log in, then I can read the topics. Maybe there's a type of blocking script or something?

I've tried deactivating all plugins except wpforo but didn't work.

Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

@chusman,

Please click on the "Mark all read" button located in forum footer then check again.

3 Replies
Xcalizorz
(@xcalizorz)
Joined: 4 years ago

Active Member
Posts: 10

Hi @sofy

I and almost all my users had the exact same problem and it was solved for my by clicking on "mark all read", but how can I "mark all read" for every user?

Is there a way to completely remove the read/unread feature?

I would be able to change things in the database or PHP code, if needed.
The problem is, that many users click on different topics and they receive a 502-Error everytime.. and I can't tell everyone to first click on "mark all read". Some won't do it because it is annoying them as well.

Would love your help!

Thanks a lot

Sofy
 Sofy
Admin
(@sofy)
Joined: 5 years ago

Support Team
Posts: 4057

Hi @xcalizorz,

Thank you for using wpForo and for contacting us. 

If you're not using the latest wpForo version, please update it to the latest one (v. 1.6.1).

This is just a cookie conflict. You should either reduce the cookie memory size or disciple the cookie from Dashboard > Forums > Tools > Privacy & Rules admin page.

 

Forum Cookies
Xcalizorz
(@xcalizorz)
Joined: 4 years ago

Active Member
Posts: 10

Superb, thanks!

There is another feature, that allows cookies but does not set the cookie to "Log Viewed Forums and Topics" and I disabled it in

wpforo > Settings > Functions > "Log Viewed Forums and Topics"

Everything seems to work fine now!
Thanks!

Share: