Notifications
Clear all

wpForo 1.x.x 502 Bad Gateway

14 Posts
4 Users
0 Likes
4,649 Views
mmoyer2655
Posts: 1
Topic starter
(@mmoyer2655)
New Member
Joined: 4 years ago

Hello,

I'm trying to set up wpforo on my website, but I'm running into an issue whenever a new user tries to "reset" their password after getting the confirmation email.  

After typing in the password I get a "502 Bad Gateway" page.  

This is a brand new install of wordpress with absolutely no changes or plugins to the default install.

I've contacted wpengine the host and they say it's an issue with the plugin. 

Any ideas?  

 

 

13 Replies
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @mmoyer2655,

Please leave your forum URL to allow us check it. As a temporary solution please navigate to Dashboard > Forums > Settings > Features admin page and disable (set NO) the "Replace Reset Password Page URL to Forum Reset Password Page URL" option.

Reply
1 Reply
indikon
(@indikon)
Joined: 4 years ago

Active Member
Posts: 7

Hello. I'm experiencing the same issue as mmoyer2655. I went through all of the settings and tested for plugin conflicts, but the problem persists.

Is there an ETA as to when this will be fixed? Disabling the "Replace Reset Password..." option works fine, but user-friendliness of user being directed to the WP dashboard after signing in is low.

 

Thanks in advance.

Reply
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @indikon,

We found this is a site specific issue, this is a conflict with other plugins. wpForo doesn't have core bug regarding to this and you should not wait for any fix. It's better to deactivate all plugins, change the theme and test it again. Then activate plugins one by, test it one by one after each plugin activation and find the conflict maker. Also please copy the Password Reset link of some test User (Subscriber) and leave it here to allow us check the URL structure.

Reply
2 Replies
indikon
(@indikon)
Joined: 4 years ago

Active Member
Posts: 7

Hi. Here is a URL string from the email sent to a new user to create a password. All of the plugins I use for this site were active when this string was sent:

https://surrogate2.wpengine.com/community/?wpforo=resetpassword&rp_key=RGn0MGEW0hS6A83X8ZjY&rp_login=test

Reply
indikon
(@indikon)
Joined: 4 years ago

Active Member
Posts: 7

I'll add that the 502 problem exists even when wpForo is the only active plugin.

wpForo is version 1.5.4. Server cache was cleared. My theme (Pro by Themeco) is up-to-date and never do I have problems with it conflicting with the plugins I often use. WordPress version is 4.9.8 and PHP version is 5.6. I've tried Chrome, Edge, and Firefox - all had the same result. 

There seems to be something else going on here. 

Thanks.

Reply
Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

I just clicked on that URL and didn't see such error. It works fine. in any case you can use the default WordPress reset password URL using this instruction: https://wpforo.com/community/how-to-and-troubleshooting-2/502-bad-gateway/#post-17905

Reply
1 Reply
indikon
(@indikon)
Joined: 4 years ago

Active Member
Posts: 7

I wasn't clear before. The link doesn't take you to the 502 error. The error occurs after you enter passwords in both fields, then hit Reset Button. It 502's every time I've tried, even when all other plugins are deactivated.

I know I'm able to use the WP password reset page, but doing so directs users to the WP dashboard after the password is reset. This isn't user-friendly at all. Given that, I'm inclined to use a different forum plugin entirely. I don't want to do that, because I've enjoyed wpForo in all other ways, but it seems like I don't have a choice.

Thanks for your time.

Reply
Sofy
Posts: 4057
 Sofy
Admin
(@sofy)
Support Team
Joined: 5 years ago

Hi @indikon,

We couldn't find such an issue on our test websites. We'll need admin accesses to find and fix it. Could you please send admin login details to info[at]gvectors.com email address?

Reply
1 Reply
indikon
(@indikon)
Joined: 4 years ago

Active Member
Posts: 7

@sofy

Sent. Thanks for taking a look. 🙂

Reply
Page 1 / 2