Notifications
Clear all

wpForo 1.x.x [Closed] Help needed urgently: Cannot create any membership accounts since installing wpforo

5 Posts
3 Users
0 Reactions
1,948 Views
Posts: 11
Topic starter
(@maria-frankfurt)
Active Member
Joined: 6 years ago

Hi, 

today I installed wpforo. It synchronized user pofiles, which already existed in my wordpress system. 

On my website I am selling memberships using a membership-plugin (DigiMember) which is connected to an external reseller (digistore24.com). Usually when someone buys a membership through Digistore24 a membership account as well as a user profile is created auotmatically. 

All registered users can use the forum. So I don't use the registration process of wpforo as the registration process is automated by the connection between reseller and membership plugin.

Since wpforo is installed the connection between my reseller and the membership software seems blocked. When someone buys my membership, no account is created any more.

Even after I deactivated wpforo it still does not work any more. 

wpforo seems to block any new membership accounts of paying customers.

What can I do? Desperately seeking help!

Maria

 

4 Replies
Sofy
Posts: 4493
 Sofy
Admin
(@sofy)
Support Team
Joined: 6 years ago

Hi Maria,

wpForo is the same WordPress registration page with different design and URL. 

Even after I deactivated wpforo it still does not work any more. 

If it doesn't work after deactivation, this means that this issue has no relation to wpForo.

Please check if there is a profile in the WordPress? Maybe it doesn't create only wpForo profiles? 

1 Reply
(@maria-frankfurt)
Joined: 6 years ago

Active Member
Posts: 11

Hi Sofy,

thanks a lot for your reply!

In the meantime I found out, that I also had to delete the browser cache after deactivating wpforo. After I did that, the automated registration process was functioning again - with wpforo deactivated. So, it is clear that with activated wpforo the registration process doesn't function, with deactivated wpforo it is functioning...

I don't have any registration page at all. (Just the wp-login.php for my wordpress admin profile and the login page of my membership plugin). 

The only plugin which uses my wordpress profiles is DigiMember - the German membership plugin. All profiles and membership accounts are created automatically, as soon as someone buys the membership through my reseller. The membership plugin and the reseller are exchanging the client's information by API connection.

With wpforo activated there wasn't created any profile nor any account for new members.

It seems that wpforo blocks the registration process for wordpress initiated by any other software which is connected by API, like my reseller and my membership plugin.

Is there a function, with which I can tell wpforo that the profiles are created by a different plugin and that it has nothing to do with the registration nor with the login process?

Is there no experience with wpforo in an environment with a membership plugin which is connected with a reseller by API?

I really would like to install wpforo as an additional feature in my member area. But it would have to comply with the existing automated registration process...

Can you help?

Kind regards,

Maria

 

 

Robert
Posts: 10527
Admin
(@robert)
Support Team
Joined: 8 years ago

Hi @maria-frankfurt,

It seems that wpforo blocks the registration process for wordpress initiated by any other software which is connected by API, like my reseller and my membership plugin.

wpForo doesn't have any affection to native WordPress registration process. I think wpForo has some conflict with server configuration and generates errors. These kind of error may affect different actions. We'd need admin login details to be able debug this issue. In case you'd need to resolve this issue please send admin login details to support[at]gvectors.com email address.

1 Reply
(@maria-frankfurt)
Joined: 6 years ago

Active Member
Posts: 11

Hi Robert,

thank you for your offer to take a look in my backend! Everything is in German - this probably would be a little difficult for you, I guess...

I decided to install the new forum on a subdomain on a fresh wordpress installation. I will have to organize for a second registration process for my club members as well as manually add or delete club members but I think the alternative would be too technically complicated in the long run. 

Thanks once more and have a good time!

Stephanie