Notifications
Clear all

wpForo 1.x.x [Solved] Logging in

13 Posts
4 Users
0 Likes
1,817 Views
2ndLifeClub.com
Posts: 36
Topic starter
(@2ndlifeclub-com)
Eminent Member
Joined: 4 years ago

Hello all - 

I've been very happy setting up the forum, even though I am not a technical person and I've had great support in this forum.

I just set up the login form (removed buddypress) and now people can not log in at all or register.  When they log in it brings them to the home page.

Also when I get a new person the member becomes a subscriber on my wordpress blog, is that normal or do I have to modify something?

My blog page is 2ndlifeclub.com/community

12 Replies
2 Replies
CrisW
(@crisw)
Joined: 4 years ago

Reputable Member
Posts: 281
Posted by: 2ndLifeClub.com

Hello all - 

I've been very happy setting up the forum, even though I am not a technical person and I've had great support in this forum.

I just set up the (1)  login form (removed buddypress) and now people can not log in at all or register.  When they log in it brings them to the home page.

Also when I get a new person the member becomes a subscriber on my wordpress blog, is that normal or do I have to modify something?

My blog page is 2ndlifeclub.com/community

 

Hi @2ndlifeclub-com . You can try checking your settings.  I'll share my setting here. 

 

 

And then also check these settings below that for BuddyPress and Ultimate Member (but I think that was put in there for those who use those plugins, but if you are not using those - like I am not using those two, make sure your settings for those are set to NO.  

 

2ndLifeClub.com
(@2ndlifeclub-com)
Joined: 4 years ago

Eminent Member
Posts: 36

Chris...thank you!  I did both of those and it still takes me to the home screen when I hit log in...

CrisW
Posts: 281
(@crisw)
Reputable Member
Joined: 4 years ago
Posted by: 2ndLifeClub.com

Chris...thank you!  I did both of those and it still takes me to the home screen when I hit log in...

Hi @2ndlifeclub-com . I just went to your website, and your login and logout Menu links on your Forum Bar seem to not have the corresponding hooks to the log in and logout pages.

Check your Menu again by going to WP Dashboard > Appearance > Menus > Select a menu to edit > (wpForo Menu)

and then under Menu Structure

Look at your Log In URL, it should be:

/%wpforo-login%/

Look at your Log Out URL, it should be:

/%wpforo-logout%/

Here's a screenshot of my settings.

Also, you really should have some type of protection on your website, like a ReCaptcha, as I have suggested in your first post here. Your website is trying to load cookies on my browser. I don't know if you are aware of that, so I am attaching another screenshot here. I suggest you minimize plugins for now, until you are more familiar with what these can do on your website, and website visitors. 🙂

Here's a screenshot of my WordPress General Setting - that will help make sure all the links within a WordPress site lead to HTTPs and not just HTTP. 

CrisW
Posts: 281
(@crisw)
Reputable Member
Joined: 4 years ago

Hi @2ndlifeclub-com - I also just noticed this, you still have two "logins" (the one on the top right corner of your website, as in the screenshot I took of your website) and the Forum Login (on the Forum Menu Bar).  

You can use just one login link because they go to the same WP Dashboard.  Another reason why this might be happening is one is overriding the other.  

If you have enabled to just use the WPForo Login Form, then all should work out.  Good luck and God bless you.  🙂 

1 Reply
2ndLifeClub.com
(@2ndlifeclub-com)
Joined: 4 years ago

Eminent Member
Posts: 36

Chris you are so amazing and I greatly appreciate all the help and support you have provided.  I do have a SSL certificate with GoDaddy, they claim it's an issue on my site and I have to pay them to fix it, I figured I would do that after I finished this venture.  

I did do the changes but it will not allow me to log in.  I don't know why I have 2 logins and honestly I'm ready to forego this venture as what I thought was going to be fun is creating more fuss than it's worth...sorry...but thank you!

Anonymous20
Posts: 1602
(@anonymous20)
Noble Member
Joined: 7 years ago

@2ndlifeclub-com

What you should do is find someone to help you with your Wordpress in general. At least for the start of your site.

Before abandoning your project as you say ...

1 Reply
2ndLifeClub.com
(@2ndlifeclub-com)
Joined: 4 years ago

Eminent Member
Posts: 36

and I've tried hiring someone to help me, not a lot of people are familiar with this program so that is how I landed here.  Chris has been awesome and really helped me to get it to where it is now, however with not a lot of knowledge out there and I can't figure it out, I'm just spending too much time on it...I was hoping it was an easy answer, "click this and it will work" but everything I'm told to do is not fixing it so I need another option or I need to move on.  As mentioned below when I changed my theme my SSL did not link, it will be fixed in the next 24 hours.

Robert
Posts: 9912
Admin
(@robert)
Support Team
Joined: 7 years ago

Hi @2ndlifeclub-com,

The login menu is wrong. It's set your home page.But the real login page is this: 

https://2ndlifeclub.com/community/?wpforo=signin

Just navigate to Dashboard > Appearance > Menus admin page, select the wpForo Navigation in Dropdown, then check the Login Menu, it should look like this:

More info in doc: https://wpforo.com/docs/root/getting-started/forum-menu/

1 Reply
2ndLifeClub.com
(@2ndlifeclub-com)
Joined: 4 years ago

Eminent Member
Posts: 36

I do have that as my log in (screenshot)

@Anonymous20, my SSL was not transferred from my old wordpress theme to my new theme, it will be updated in the next 24 hours.

Page 1 / 2