Notifications
Clear all

[Closed] Login & registration page not loading

5 Posts
2 Users
0 Likes
988 Views
Posts: 3
Topic starter
(@meria11)
Active Member
Joined: 1 year ago

When I click on the register and/or login link, both pages do not load. All it does is reload the default forum page. 

 

Enable User Registration + Enable User Registration email confirmation settings are enabled. Wordpress membership anyone can register is checked.

 

Board slug matches page slug. Forum pageid links correctly to page. 

 

I can't figure out what is causing the problem. Can you please help? Thank you. 

4 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

Hi @meria11,

I see that you are using another Login/Registration form, in this case the issue is not related to wpForo, as wpForo doesn't handle the Login/Registration just provides own forms, but you dont use wpForo's Login/Reg forms.

Posts: 3
Topic starter
(@meria11)
Active Member
Joined: 1 year ago

Hi @chris

Thanks for your reply. I was not aware I was using another Login/Registration form. Would it be another plugin I have that's generating the Login/Registration page instead? Or is there a setting I can enable that would make wpForo the default?

Thank you

Posts: 3
Topic starter
(@meria11)
Active Member
Joined: 1 year ago

Hi @chris

I haven't figured out the solution. But I did discover something.

For my website, the forum is meant to be a feature for a private community. After some investigation, it seems when someone joins through my website, the user profile that gets created automatically connects to the forum and gives them access. I suppose this is what you meant by me using another Login/Registration form. Although I didn't set it up this way, this "problem" is exactly what I wanted.

Thanks for your insight. 

1 Reply
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@meria11,

1. You have JS errors which should be fixed(not related to wpForo)

2. the form which is used now, notes that the registration is paid, I don't know how the payment part works after submitting the Reg Details. But note that wpForo form doesn't have payment options, just clean login/reg fields.

3. I tried to reg in your website, but couldn't submit and check out, got the following message:

"There are JavaScript errors on the page. Please contact the webmaster."

So if you fix the JS errors, the Reg form which is used now should work.

Not sure, but the reg form can be part of your premium membership plugin.