Notifications
Clear all

wpForo 1.x.x [Closed] Can't Add Forum error.

12 Posts
3 Users
1 Reactions
351 Views
PawelK
Posts: 26
Topic starter
(@pawelk)
Eminent Member
Joined: 5 years ago

I am getting an error that says "Can't Add Forum." It doesn't give me any other information that I can see. Can anybody help with the issue?

11 Replies
Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

@pawelk,

Please provide Forum URL, screenshots of the error and where you get, and also, please give more details, when and how you get it.

PawelK
Posts: 26
Topic starter
(@pawelk)
Eminent Member
Joined: 5 years ago

ZNienacka Forum – ZNienacka

Dashboard->Forums->Forums->Categories & Forums->Add new

Then I am adding new as usually and are getting the error message Can't add forum.

 

3 Replies
Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@pawelk,

please provide admin access, need to check as an admin, send the credentials to info[at]gvectors.com email, mention this topic in the email, and let me know here that  you have sent the email.

PawelK
(@pawelk)
Joined: 5 years ago

Eminent Member
Posts: 26

@chris I did it. Thank you.

Chris
(@chris)
Joined: 3 years ago

Famed Member
Posts: 3650

@pawelk,

We will check and let you know.

Chris
Posts: 3650
(@chris)
Famed Member
Joined: 3 years ago

HI @pawelk,

When you have updated wpForo to 2.x.x version, wpForo had structural changes in the Database, now you have downgraded wpForo to 1.x.x version and because of that wpForo's new 2.x.x Database structure doesn't work with old version.

So now if you have a backup of the DB, without the structural update to 2.x.x version, you can use that, and the problems would be fixed, if you don't have a 1.x.x structural backup, the only option is to update wpForo to last version(2.x.x) and also update wpForo addons to the last version, as the addons 2.x.x version doesn't work with wpForo 2.x.x, only 3.x.x version of the addons work with wpForo 2.x.x version.

5 Replies
PawelK
(@pawelk)
Joined: 5 years ago

Eminent Member
Posts: 26

@chris thank you, but it won't help as I didn't do downgrade to 1.9.9. I have restored whole forum and portal from the D-1 backup together with DB.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2614

@pawelk Just enable Standard Wordpress DEBUG TO A LOG and see the errors.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2614

Posted by: @pawelk

@chris thank you, but it won't help as I didn't do downgrade to 1.9.9. I have restored whole forum and portal from the D-1 backup together with DB.

Here

https://wpforo.com/community/how-to-and-troubleshooting-2/i-lost-my-plugins/

you say wpForo 2.15, now you say 1.9.x. What is correct?

 

PawelK
(@pawelk)
Joined: 5 years ago

Eminent Member
Posts: 26

@dimalifragis exactly what is written above. I did upgrade to 2.1.5 and then restored to 1.9.9 back. But I did restore, not downgraded as @chris has written.

dimalifragis
(@dimalifragis)
Joined: 4 years ago

Famed Member
Posts: 2614

@pawelk Ok, then Wordpress debug to a log will tell you what is wrong.

Or F12 browser console maybe.